Find the answer to your Linux question:
Results 1 to 4 of 4
I am having troubles with the display in the TTY windows. If I try to use vim after ctrl-alt-1, all the characters start to flash, and the font changes to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2008
    Posts
    9

    Font display problems in tty


    I am having troubles with the display in the TTY windows. If I try to use vim after ctrl-alt-1, all the characters start to flash, and the font changes to a hybrid of latin and greek characters.

    `reset` works to correct the display, but vim is useless, as are other terminal programs.

    I have tried to change the font with `setfont`, but that has not had any effect. I have googled for an answer, but nothing obvious turns up.

    The problem started after an upgrade to a new kernel, but persisted after trying to run an older kernel.

    Currently I am running Ubuntu 10.04, kernel 2.6.32-47, on a desktop with an nvidia graphics card, GTS250.

    What I need is to be pointed in a direction where I can change the default TTY displays, as obviously some setting has been overwritten.

    Any help appreciated.

  2. #2
    Linux User
    Join Date
    Dec 2011
    Location
    Turtle Island West
    Posts
    327
    Does TTY work properly right after boot and before XSession?

  3. #3
    Just Joined!
    Join Date
    Jun 2008
    Posts
    9
    Quote Originally Posted by Miven View Post
    Does TTY work properly right after boot and before XSession?
    Grub works properly. I haven't tried booting directly into a TTY shell. Other OS's don't have the problem when I boot into them, so I think it's a configuration issue in just this one.

  4. #4
    Linux User
    Join Date
    Dec 2011
    Location
    Turtle Island West
    Posts
    327
    Hmm.

    I have strange issue, and I wonder if it's related.

    When first I boot, my screen is in default 80x24 mode for the BIOS POST. When Linux 2.6.6 takes over, it switches to 1024x768(128x48 with 8x16 font). Nice penguin logo. All is good.

    Login to TTY, no problem. Fire up XWindows, screen goes black, changes modes, then comes up all color and pretty. No problem.

    Use CTRL-ALT-1 (2,3,4,etc) to switch back to TTY. Sometimes it works, sometimes it's as if I turned the monitor off. Flip back to X, sometimes black. CTRL-ALT-PLUS, then CTRL-ALT-MINUS, to flip video modes fixes the problem. Unfortunately, there is no equivalent in Linux console (TTY).

    Just last week, I bought a 19" cheapo Viewsonic 903b LCD monitor and plugged it in. This thing has even more problems changing modes. Boot mode 80x24 is way off the left of the screen, Linux 1024x768 is better but still off the left, and XWindows works fine after auto adjust on the monitor. But try to go back to TTY, I get [NO SIGNAL] on the monitor. Why?

    My guess it has something to do with video card driver. I used to have nVidia card, and had tons of trouble with it. This one is SIS. Much less trouble.

    I do know that video cards can have their registers and stuff set that persist between boots. It's that deep magic that some large software manufacturers pay big money to keep secret. Maybe something about your new kernel tweaked your video card the wrong way, to some non-default settings, and now nothing knows how to tweak it back to default.

    It's like toggling the byte at 0xC010 or something. It makes the video card do funny things.

    Just out of curiosity, if you boot XP or something, play with the video modes, then go back to Linux, does it fix the problem?

    Peace and Cheer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •