Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Have someone use YCM as vim plugin?

    However I met a problem when I installed YCM as vim plugin,
    I followed the link YouCompleteMe instruction in Github
    for full installation, but in second step, after I installed the Vundle and adding a adding a Bundle 'Valloric/YouCompleteMe' line to my vimrc.
    Strangely when I open vim again, it tells me an error:
    Error detected while processing /home/free/.vimrc:
    line 110:
    E492: Not an editor command: Bundle 'Valloric/YouCompleteMe'
    Press ENTER or type command to continue

    I want to know why vimrc can't identifier these word? Thanks.
    Any advices will appreciated.:)


  2. #2
    hello and welcome, pepper!

    Did you install the Vundle (VIM Bundle) plugin manager? Also you have to modify your ~/.vimrc file to use Vundle, see the description here (scroll down to the Vundle section).

    Did you also compile the plugin, as described here (near top of page)?

  3. #3
    Thanks atreyu, I read the relative documents and I had found the reason why. I put the Bundle 'Valloric/YouCompleteMe' line before "set rtp+=~/.vim/bundle/vundle/" so it can't identify. Thanks again!

    But YCM seems not work yet, I should investigate however...


  4. $spacer_open
  5. #4
    Quote Originally Posted by pepperfairy View Post
    But YCM seems not work yet, I should investigate however...
    did you compile it?

    if you do get it working, considering posting your solution here, for the benefit of others.


  6. #5
    Through my efforts, I have compiled YCM successfully finally!
    There's some sharing as shown below:

    When you prepare to compile YCM, you can simple to install it by running Or want to compile it by yourself these tips maybe useful to you.
    First, you should read the full installation guide carefully. And you must make sure your vim version(7.3.584+ is required), if not you need compile vim from source.

    Secondly, you must make sure your clang version, YCM needs 3.3(version 3.2 at least, I used 3.3). Because In, version 3.3. offical binaries only supported Ubuntu13.04/12.04.2/10.04.4 , So I strongly recommended you select
    release of Ubuntu version carefully.(I used 13.04 x64 this time.)
    This is the mainly reason that I compiled failed last time(I used ubuntu11.10 and use clang 3.1).

    Then you can follow installation instruction, generate makefile as the issue below:
    cmake -G "Unix Makefiles" -DPATH_TO_LLVM_ROOT=~/ycm_temp/llvm_root_dir . ~/.vim/bundle/YouCompleteMe/cpp
    then use "make ycm_core" to build ycm_core environment.

    Last thing, you should need put the in your home root directory, because YCM will look for this file in the directory of the opend file or in any directroy above it in the hierarchy of recursively.
    This file include compiling flags, so you maybe need change the correct flags for your project(c or c++).it's important.

    BTW, I installed syntastic with vundle as well. You just adding line "Bundle 'scrooloose/syntastic' " in your vimrc, and execute :BundleInstall in vim. But it seems that it can't display error ballons when mouse point to it and Statusline flag, I haven't found the reason so far.

    That's it. Well Done, enjoy coding!
    Last edited by pepperfairy; 08-10-2013 at 12:21 PM.

  7. #6
    excellent, thanks for posting your detailed solution! marking as Solved for you. Note that you can do this too using the Thread Tools link at the top of the page.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts