Find the answer to your Linux question:
Results 1 to 2 of 2
I am trying to install DBD::Oracle, but It says that I need DBI version 1.2. Code: DBI version 1.2 required--this is only version 1.18 at Makefile.PL line 20. BEGIN failed--compilation ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2003
    Posts
    1

    Installing DBD::Oracle


    I am trying to install DBD::Oracle, but It says that I need DBI version 1.2.
    Code:
    DBI version 1.2 required--this is only version 1.18 at Makefile.PL line 20.
    BEGIN failed--compilation aborted at Makefile.PL line 20.
    I installed DBI-1.20 from CPAN, which seemed to install fine, but I still keep getting the above error when I try & install DBD::Oracle?

    Any ideas?

  2. #2
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Which dist are you using??

    Try to execute..i think this is the format..

    Code:
    perl -e -MDBI
    To see if perl can use your intalled DBI and if its the right version.
    Regards

    Andutt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •