Find the answer to your Linux question:
Results 1 to 2 of 2
i was wondering if someone could tell me how to set my LOCALE. Everytime I install anything with apt i get an error message saying: perl: warning: Setting locale failed. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32

    Setting LOCALE


    i was wondering if someone could tell me how to set my LOCALE. Everytime I install anything with apt i get an error message saying:

    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = "en_CA:en_US:en_GB:en",
    LC_ALL = "en_US",
    LANG = "en_CA"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory

    i would like to get rid of this annoying message so any help would be great. Thanks.

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    I found this at G4L. Hope it helps.
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •