Find the answer to your Linux question:
Results 1 to 3 of 3
I had a script written recently, that requires a perl 5.8 module threads.pm my dedicated server is running perl 5.6 but with being an ensim control system, which isnt compatible ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2003
    Location
    Australia
    Posts
    4

    Supplimentary Perl 5.8


    I had a script written recently, that requires a perl 5.8 module threads.pm
    my dedicated server is running perl 5.6 but with being an ensim control system, which isnt compatible with perl 5.8 I couldnt install 5.8 as the main perl executable, so a programmer installed it at
    #!/usr/local/bin/perl5.8.0
    as a secondary location however the script still throws up
    must have perl 5.8 its still only seeing 5.6 even though the path to perl is still #!/usr/local/bin/perl5.8.0 at the top of the scripts

  2. #2
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Run strace ./script to see which perl binary it is opening. Also try adding this line to your perl script:

    use lib "/usr/lib/perl5/5.8.0/i686-linux/";
    Or it might be 586 or whatever directory you have your 5.8 modules in.

  3. #3
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Just install you specific perlversions under /opt/perl-version and then symlink under /usr/bin/perl to the perversion you want to run with. Then you can still have #!/usr/bin/perl in your scripts and just switch easylie between many versions. You dont need to update your PATH-variable either.
    Regards

    Andutt

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •