Find the answer to your Linux question:
Results 1 to 5 of 5
Hi guys, my post is in the following forum: http://www.linuxforums.org/forum/topic-42936.html Basically it involves trying to install irqtune to see if I can solve serial port + ext modem issues on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    23

    Compiling Problems / Makefile Errors


    Hi guys, my post is in the following forum:
    http://www.linuxforums.org/forum/topic-42936.html

    Basically it involves trying to install irqtune to see if I can solve serial port + ext modem issues on Mandrake 10.2 and getting errors while compiling which seem to be related to a Makefile. How do I correct this?

    If you need more info feel free to ask

    Thanks.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    What is the exact error message?

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    23
    Code:
    [root@localhost irqtune]# make install
    (cd /usr/local/irqtune/sbin ; make -f /usr/local/irqtune/src/Makefile CDEBUG='' CFLAGS_EXTRA='' IRQTUNE_HOME=/usr/local/irqtune IRQTUNE_VERSION=0.6 INSTALL=simp le INSTALLER=/usr/local/irqtune/sbin/irqtune SBIN=/sbin install)
    make[1]: Entering directory `/usr/local/irqtune/sbin'
    /usr/local/irqtune/sbin/irqtune -i simple /sbin /usr/local/irqtune
    make[1]: /usr/local/irqtune/sbin/irqtune: Command not found
    make[1]: *** [install] Error 127
    make[1]: Leaving directory `/usr/local/irqtune/sbin'
    make: *** [install] Error 2

  4. #4
    Linux Enthusiast
    Join Date
    Jan 2005
    Posts
    575
    *** Whoops ***

  5. #5
    Linux Enthusiast
    Join Date
    Jan 2005
    Posts
    575
    Right then.I got so intrigued by this that I decided to download the programme
    and see if I could make it compile.I did manage to compile it but it doesn't
    run properly.
    Since this may have some educational value I'll take it one step at a time.
    For more background you can also read the thread linked to above.

    The error message /usr/local/irqtune/sbin/irqtune: Command not found (see code above)
    is completely mysterious since the executable is actually there ! I got the same
    error even when I tried to type /usr/local/irqtune/sbin/irqtune from the command line
    of the TC-shell.
    But trying to run it from the Bash shell gives you something helpful:
    /lib/ld-linux.so.1: bad ELF interpreter: No such file or directory Ok , so
    at least this makes sense.Next I try /lib/ld-linux.so.2 /usr/local/irqtune/sbin/irqtune and got irqtune: error while loading shared libraries: irqtune: cannot open shared object file: No such file or directory
    By the way you get this executable just by untarring the tarball.So next thing
    to try is to compile from scratch.I erased all object files and machine code
    executables which came with the tarball.The Makefile inside /usr/local/irqtune
    gives you several options.The most drastic one seemed to be make warp9
    so I tried that.I won't give the full output but here are 3 parts which stand out:
    /usr/include/asm/bitops.h:328:2: #warning Using kernel headers in
    userspace: atomicity not guaranteed

    I don't know what this means.
    irqtune/src/load.c:59: warning: implicit declaration of function `printk'

    cc1: warnings being treated as errors

    In order to fix the last one I went to line 26 of /usr/local/irqtune/src/Makefile and erased the -Werror part.
    It turned out that it was enough for it to compile.(By the way in order
    to change where it gets installed you need to modify line 25 of
    /usr/local/irqtune/Makefile Note that this is a different Makefile).
    But when I tried to run it it gave me some error message and
    suggested that I rerun it with the -e option.So I tried that.I won't give
    the full output but here's a taster:
    Warning: kernel-module version mismatch
    /home/pmt2/2004/cube/irq/irqtune/sbin/irqtune_npr.o was compiled for kernel version 1.0.0
    while this kernel is version 2.4.20-30.9

    At this point I'm out of ideas.I don't have a use for this programme myself ,
    I just thought it was an interesting challenge but I don't know how to make
    any more progress.If anyone manages to go further I'd love to see it.
    You would need to download it of course.Just google irqtune.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •