Find the answer to your Linux question:
Results 1 to 2 of 2
sorry guys i have posted this over @ gamedev but didn't get much response so i thought i would try here: I am running fedora core 4 and i am ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    1

    Kdevelop OpenGL linking problem


    sorry guys i have posted this over @ gamedev but didn't get much response so i thought i would try here:

    I am running fedora core 4 and i am trying to port one of my windows app's over to linux. I am using KDevelop.

    when i run my app it is reporting the GL renderer as Mesa GLX Indirect, but i do have the proper ATI drivers installed, glxinfo says ATI. so anyway i check what my program is linking to and ldd says this

    libGL.so.1 => /usr/lib/libGL.so.1 (0x008a2000)

    yet when i run ldd on glxinfo it reports the correct one:

    libGL.so.1 => /usr/lib/ati-fglrx/libGL.so.1 (0x00111000)

    so i try a very tiny app and create my own Makefile and use these linker options

    -L"/usr/X11R6/lib" -L -lGL and yep it links against the correct libGL .

    So in KDevelop i put the exact same linker options into Project->Project Options->Configure Options->Linker Flags

    Yet it still links against the wrong libGL. How do i fix this, it is very obvious it is something in the way KDevelop does things that is causing this.

  2. #2
    Linux User
    Join Date
    Aug 2005
    Location
    Italy
    Posts
    401
    Maybe you must set a -L flag like

    -L/usr/lib/ati-fglrx/

    isn't it?
    When using Windows, have you ever told "Ehi... do your business?"
    Linux user #396597 (http://counter.li.org)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •