Find the answer to your Linux question:
Results 1 to 2 of 2
When I try to compile the latest version of SVN / Subversion from source code, I got the following error on the 2 static library: libexpat and libdb4. Both static ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Oct 2004
    Posts
    114

    Question Libtool Warning: Static Library Moved


    When I try to compile the latest version of SVN / Subversion from source code, I got the following error on the 2 static library: libexpat and libdb4.

    Both static library exist on /usr/lib.

    Apparently there is an extra "/" (slash) on the path:

    libtool: link: warning: `/usr/lib/gcc-lib/i386-redhat-linux/3.4.4/../../..//libexpat.la' seems to be moved

    libtool: link: warning: `/usr/lib/gcc-lib/i386-redhat-linux/3.4.4/../../..//libdb4.la' seems to be moved

    If one of the slash before "libexpat.la" and "libdb4.la" is deleted, it will point to the correct location of the static library. (/usr/lib/libexpat.la).

    I had updated the libtool with the latest version, but the problem is unresolved.

    How to solve this problem?

    How to delete the extra slash on the path?

    Thank you.

  2. #2
    Linux User fernape's Avatar
    Join Date
    Dec 2005
    Location
    Holland
    Posts
    301
    Are you sure this is a libtool problem and not a Makefile or configure mistake?

    Best regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •