Find the answer to your Linux question:
Results 1 to 6 of 6
hey everyone, ive been having problems with my 'make'.... seems to dump out wehn i do a ./configure cuz im missing some libraries ... [ configure:23416: error: Qt (>= Qt ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18

    make problems


    hey everyone, ive been having problems with my 'make'.... seems to dump out wehn i do a ./configure cuz im missing some libraries
    ...
    [
    configure:23416: error: Qt (>= Qt 3.1 (20021021)) (headers and libraries) not found. Please check your installation!
    For more details about this problem, look at the end of config.log.
    ]
    anyone know what i can do? i have apt-get if i need some libraries

  2. #2
    Linux Newbie zdawg's Avatar
    Join Date
    Jan 2004
    Location
    Canada
    Posts
    218
    What does it display at the end of config.log?
    Me & Myself just ganged up on I....... Now We all have problems..and none of Us are speaking!
    bash-3.00$ uname -a
    SunOS sparky 5.11 OpenSolaris-swa sun4u sparc SUNW,Ultra-Enterprise

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Well, it does seem that you need Qt... if you already have Qt, it probably means that you need the development package. Most library packages are distributed in two parts - one that contains the binary files needed to run programs that use the library, and another part that contains the header files and linker info needed to compile programs that use the library.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18
    what i posted is doubled at the end of config.log

  6. #5
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    you need qt 3.1 or higher devel packages

    if rpm form these woudl be called

    libqt3-devel-3.1 (or 3.2 on the end)

  7. #6
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18
    i got an

    E:Couldn't find package libqt-devel-3.1

    im using apt-get btw...... i apreciate the help tho man thanks a million, but please im going to need the make like 3 days ago:S

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •