I need to send a packet to myself, and it has to go through the network. It seems linux will go to great lengths to keep you from doing this. First the simple case, one ethernet device, call it eth0 with address 10.0.0.1 and we tell it our gateway is out in the network 169.whatever. The kernel will simply send it to itself, and eth0 won't even see the packet, much less our 169 gateway. If we turn off our loopback device our packet will just never leave.

The following setups have resulted in the same problem:
-One eth device, multiple pseudo addresses (eth0:0 to eth0:1)
-Two eth devices, multiple addresses
-Routing table with no route/route to the specified device/route forced through the second device

It seems the packet never even sees the routing table, linux just decides the message is for itself and it never goes. How do I turn off routing to itself or configure a connection through the outside?

Any ideas, anyone?

Thanks!

-n