Find the answer to your Linux question:
Results 1 to 5 of 5
Okay, I am fairly new to linux and have just installed Redhat 9. The only problem so far is I can't get my video card drivers to work. I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    3

    ATI driver problem....


    Okay, I am fairly new to linux and have just installed Redhat 9. The only problem so far is I can't get my video card drivers to work.

    I have a ATI Radeon 9200, can anyone step me through this little crisis?

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Well, what exactly is wrong? That is, what happens and what error messages do you get?

  3. #3
    Just Joined!
    Join Date
    Jun 2004
    Posts
    3
    Quote Originally Posted by Dolda2000
    Well, what exactly is wrong? That is, what happens and what error messages do you get?
    Well, I restart the computer after I have specified which graphics drivers to use, a little blue window pops up and says that it cannot start X windows or some such, then it asks me to login with the root password, then it goes through some tests, finally settling on the VESA generic drivers.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Hmmm... it might be that the open source drivers do not yet support the latest Radeon cards. I haven't used ATi in ages, so I don't really know. Try checking out ATi's proprietary driver on their homepage.

  6. #5
    Just Joined!
    Join Date
    May 2004
    Location
    Columbus, Ohio
    Posts
    16
    This worked for Fedora Core 1

    Well, I had much the same problem that you did a coupla weeks back and had to do the following, assuming that you can load up KDE/Gnome etc:

    1) I downloaded the ATI driver from the website and performed a force install using the rpm -Ui command (mainly due to a pesky Mesa driver conflict that I had..grrr...you should be fine reinstalling the drivers after you issue rpm -e to remove your current installation.

    2) Run "glxgears" in a terminal to check your fps rate. If it is up in the 1000+ range then sit back, relax and fire up tuxracer . If your fps is nowhere near this then try the "glxinfo | grep direct" command to see if you have direct rendering support enabled. If the output is negative then,

    3)What I found to work was to edit my /etc/X11/XF86Config file (be sure to make a backup!). Look under Section "Device" and you should see this
    Section "Device"
    Identifier "Videocard0"
    Driver "radeon"
    VendorName "Videocard vendor"
    BoardName "ATI Radeon 9200SE"
    Now all you need to do is to add Load "dri" to the Section "Module" bit so,
    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "fbdevhw"
    Load "glx"
    Load "record"
    Load "freetype"
    Load "type1"
    Load "dri"
    Caveat! I may have left out some bits here so make backups! Also you may need to add a Load "glx" line as well as a Load "dri" line as in 3) above but I doubt that should be the case. I'm no expert so I will defer to any gurus who may be cringing at my ham-handed fix.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •