Find the answer to your Linux question:
Results 1 to 4 of 4
hi, i am trying to install the libnss_pgsql module following carefully the steps from a guide i found on the net. I was on the compilation part and did the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    2

    Question undefined reference to `rpl_malloc'


    hi,
    i am trying to install the libnss_pgsql module following carefully the steps from a guide i found on the net. I was on the compilation part and did the following:
    1)./configure --with-gnu-ld
    2)make
    3)ld src/.libs/libnss_pgsql.so
    ld: warning: cannot find entry symbol _start; not setting start address
    src/.libs/libnss_pgsql.so: undefined reference to `rpl_malloc'
    src/.libs/libnss_pgsql.so: undefined reference to `rpl_realloc'

    it is said that there should be no more warning/error than the first line for the module to work, i tried google unfortunately i have yet to find a solution. i am fairly new to fedora/linux so please bear with me

    Regards,
    kris

  2. #2
    Just Joined!
    Join Date
    Jun 2008
    Posts
    2
    Hi All,

    I'm facing the exact same problem as stated above.

    I downloaded the source code for "check" from "http://sourceforge.net/projects/check/".
    $ ./configure
    worked correctly; after which I gave 'make'. This fails with the following error:
    ../src/.libs/libcheck.so: undefined reference to `rpl_malloc'
    ../src/.libs/libcheck.so: undefined reference to `rpl_realloc'
    collect2: ld returned 1 exit status
    make[2]: *** [check_check] Error 1

    Any help would be greatly appreciated!

    Regds,
    G

  3. #3
    Just Joined!
    Join Date
    Jun 2008
    Posts
    2
    Hi Nishit,

    This is in response to your private message regarding the above error.
    When you run the "configure" script, you'll see that a file called "config.h" will be created in the same directory.

    Search for and comment out the following lines in this file:
    #undef malloc
    &
    #undef realloc
    After this run make, and then make install.

    Imp note: Do not run "configure" again after editing "config.h" because your changes will be overwritten.

    Post back here if it works!

    - Googie

  4. #4
    Just Joined!
    Join Date
    Aug 2008
    Posts
    1
    gthm159 you are right.Thank u

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •