Find the answer to your Linux question:
Results 1 to 8 of 8
Hi, I am running RH-9 on P4-1.7G. I am getting a message whenever I try to shutdown linux. The message appears after the line "halting filesystems.." it says - ....0x4 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12

    error when shutting down.


    Hi,
    I am running RH-9 on P4-1.7G. I am getting a message whenever I try to shutdown linux. The message appears after the line "halting filesystems.."
    it says -
    ....0x4 Seek Complete Error
    ... 0x51 Device Status Error....blah blah...

    Help me out to solve this.

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Location
    Le Inde
    Posts
    4
    hi balakrishnan,
    Perhaps, these mite help:

    1). http://groups.google.com/groups?hl=e....pl%26rnum%3D2

    2). http://groups.google.com/groups?hl=e...3DN%26tab%3Dwg

    3). http://www.computing.net/linux/wwwbo...rum/20720.html

    4). As you can see from the above posts, it might be just a dma error. Try posting it on your hdd company's forum.

    also, "putting this on grub ide0=0x1f0,0x3f6,14 idebus=66 makes some boxes to work properly"

    post if it helped ya,
    Dog Star

  3. #3
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12

    thanks but...

    It's definitely not a DMA error. It has got to be something else. One more thing \...regarding the new suggestion of yours I want to know ow exactly to include it in grub.

  4. #4
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12

    the message...

    I have tried to produce an exact copy of the message I see during the final stages of teh shutdown process. Check out if this helps you to suggest a solution for the problem I am facing.

    unmounting file systems [OK]
    Halting system...
    flushing ide devices: hda hda : task_no_data_intr: status=0x51 {DriveReady SeekComplete Error}
    hda : task_no_data_intr : error=0x04 {DriveStatus Error}
    hdc
    Power down

    (I also tried out passing the option suggested by you into GRUB...but it didn't make any difference)

  5. #5
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    What kernel version? Seems from looking around that its not a fatal error try the 2.6.7 kernel version and it should fix it also compile in the IDE bug fixes.

  6. #6
    Just Joined!
    Join Date
    Jun 2004
    Posts
    12

    I tried that too...

    I am currently running kernel 2.6.7. But of no use. There is an oprion if you remember which says "use multimode by default". When I read the info about this option, it said that should I get an error like the one I am getting I should say "Y" to the option or else "N". I first tried with "N", there was no difference; but when I compiled with the option selected, there was a huge difference. Now instead of the message coming once it comes six times.

  7. #7
    Just Joined!
    Join Date
    Jul 2004
    Location
    Le Inde
    Posts
    4

    Maybe

    hi,
    Sometimes, this seem to happen with old/incompatible cables which doesn't support the udma mode that you're running. Check your'e cable or try your friend's cable to see if this is the problem.

    ciao,
    siriusb

  8. #8
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    you might wanna try browsing through teh kernel options and looking for anything suspicous.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •