Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Hi guys! I'm having a problem installing Fedora 7 on my pc... I insert the DVD (x86 64) downloaded from official website. I select the graphical mode (tried also the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Posts
    8

    Fedora 7 Installation crash! NEED HELP!!


    Hi guys!
    I'm having a problem installing Fedora 7 on my pc...
    I insert the DVD (x86 64) downloaded from official website.
    I select the graphical mode (tried also the text mode) and it loads some drivers: fw_ohci ( ), nvidia_sata and pata_amd.
    Everything is ok until Anaconda checks for previously installed distributions: Black screen (to main terminal) - it says:

    (anaconda:822): HtmlUtil-CRITICAL **: html_stream_cancel: assertion 'stream->cancel_func != null' failed
    install exited abnormally [1/1]
    sending termination signals...
    etc...

    I've absolutely no idea what's causing the error... I've just bought this new pc (on the old one I had FC6 working great, apart from the 800mhz cpu) here are the specs:

    CPU AMD Athlon 64 X2 5600 (2 cores clocked 2800Mhz)
    RAM 2GB DDR-2 800Mhz
    1 SATA HDD 250GB
    1 IDE HDD 40GB M
    1 IDE DVD Burner drive
    2 integrated NICs on ASUS MB M2N-SLI DELUXE
    nVidia GeForce 8600GT

    I've partitioned the 250GB HD into 4 pieces: 1 ntfs for XP; 2 250MB ext2 for GRUB; 3 3GB SWAP; 4 10GB ext3 for FC7...

    Anyway... Is there a way to log and save the other terminals?? (the problem is that the system hangs and doesn't let you interact with terminals) Otherwise tell me and I'll post photos (how I reduce the character size on terminals?).

    Trying FC6 64 no X starts, in text mode same error as in F7.
    Fedora 7.9 64 (8 beta1) same problem.
    As I read on other forums that some people had same error message because of raid controllers' drivers, I tried the noprobe mode and used only the pata_amd driver (which includes IDE channels ) to get the DVD working: same problem.

    ...that's it... I need some help

  2. #2
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    If it's a problem with raid drivers, you might try booting with the nodmraid option.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  3. #3
    Just Joined!
    Join Date
    Nov 2007
    Posts
    8
    Tried it... It's not related to raid, I own a Jmicron RAID controller on the MB but it's disabled, nodmraid crashes anyway

  4. #4
    Just Joined!
    Join Date
    Nov 2007
    Posts
    8
    No one's suggestions??

  5. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Fedora 8 was released earlier today, so you might try that. It should have better hardware support.
    oz

  6. #6
    Just Joined!
    Join Date
    Nov 2007
    Posts
    8
    YAY!! Thanks Fedora 8 resolved that!
    Thank you for help guys...
    Anyway, I'm having another little problem: sometimes the mouse hangs while doing nothing in particular and if I try to restart/kill X it wont, just desktop picture and so I have to reboot.

  7. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    It looks like Graphics Card driver problem. Execute this
    Code:
    lspci | grep VGA
    cat /etc/X11/xorg.conf | grep Driver
    Post output here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #8
    Just Joined!
    Join Date
    Nov 2007
    Posts
    8
    Noticed it happens almost everytime I use amarok... but randomly, some seconds/minutes after I started it.
    Mmmh... It can be related to a xorg.conf misconfiguration, or some issues with my audio card: nvidia's MCP55 High Definition Audio (MB integrated), and the driver is snd-hda-intel
    My mouse is wireless from Logitech, identified as "LOGITECH USB RICEVER" in linux.

    Anyway this is the output:

    [root@localhost andrea]# lspci | grep VGA
    bash: lspci: command not found
    [root@localhost andrea]# cat /etc/X11/xorg.conf | grep Driver
    Driver "mouse"
    Driver "kbd"
    Driver "nvidia"


    Here my xorg.conf:

    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"

    # ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
    # ModulePath "/usr/lib/xorg/modules"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "it"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    ModelName "LCD Panel 1024x768"
    HorizSync 31.5 - 48.0
    VertRefresh 56.0 - 65.0
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nvidia"
    Option "AddARGBGLXVisuals" "true"
    Option "RenderAccel" "true"
    Option "AllowGLXWithComposite" "true"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection


    I managed to kill -segv X because of the mouse crash an I was sent back to a virtual terminal. I restarted X and a big nVidia full screen logo appeared. Have to reboot. Maybe it's related to the nvidia driver?

  9. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    How did you install Nvidia Driver?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #10
    Just Joined!
    Join Date
    Nov 2007
    Posts
    8
    I downloaded it from the nVidia website and followed the instruction in terminal...

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •