Find the answer to your Linux question:
Results 1 to 3 of 3
I am running Fedora Core 2 Yum updates have been no problem for months. I recently installed bit torrent client azuerus and some java to make it work. Now yum ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    2

    yum cannot resolve dependencies to update


    I am running Fedora Core 2 Yum updates have been no problem for months. I recently installed bit torrent client azuerus and some java to make it work. Now yum update cannot continue because :
    "Package commons-modeler needs lib-javax-management-1.1.1.so and this is not available."
    I assume this is related to the java I installed. I found the RPM for
    lib-javax-management-1.1.1.so and when I tried to installed it was informed it was already installed.
    How can I exclude this one update so I can update everything else?
    tried yum --exclude=commons-modeler update
    tried yum --exclude-commons-modeler* update
    Should I try to remove commons-modeler?
    Thank you very much for any help. :?:

  2. #2
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    you should rebuild the rpmdatabase so yum knows that it has been installed
    Code:
    rpm --rebuilddb
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  3. #3
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    wow, didnt realize how dead this string was.....
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •