Find the answer to your Linux question:
Results 1 to 6 of 6
Hi! I have just installed RH9 on my PC and I am not able to hear any sound at all. Can someone please help?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    6

    No Sound


    Hi! I have just installed RH9 on my PC and I am not able to hear any sound at all. Can someone please help?


  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    www.syracuse.com
    Posts
    119
    which method have you tried, oss, alsa etc?
    alsaconf should do it for alsa.
    do you have any errors messages?
    what programs have you tried that don't get sound?
    maybe its a module with that program.
    are you running kde, gnome etc?
    kde has its arts that can conflict with other techniques.

  3. #3
    Just Joined!
    Join Date
    Jun 2004
    Posts
    6
    Hi. Thanks for helping. I am really new to linux and I'm not aware of what oss and alsa are.

    When I try and run sndconfig , this is the error message i receive :
    bash: sndconfig: command not found

    There's no sound when I open a window or etc. Also, when I click on "Play test sound", there is no sound at all.

    Lastly, I am running Gnome.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Jul 2004
    Location
    www.syracuse.com
    Posts
    119
    which distro you using?

    most distros now come with alsa. that is what i use for sound.
    to configure alsa just type in alsaconf in a terminal.
    this is the recomended routing.

    or you can go to /etc/rc.d/rc.modules and just activate the module you need. for me i would activate emu104k since i have a soundblaster. you activate a module by just deleting the # sign in front of it. then next time the script is read it will load that module.

    these instructions are based on my experience with slackware. but should work in most distros.

  6. #5
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    are u sure that nothing is set to mute?in kde mix,kamix,or qamix should be checked to assume that that nothing is set to mute(master or pcm).
    although if your sound card is pci connected check if the module is loaded.use the commands lspci and lsmod(to see if sound module is loaded).
    then make sure that if you trying to play mp3's or so you maybe need to download plugin for xmms.you can find it here:http://www.gurulabs.com/downloads.html
    good luck!
    Linux For Ever!

  7. #6
    Just Joined!
    Join Date
    Jun 2004
    Posts
    6
    I am very sure nothing is set to mute. Also the commands he commands lspci and lsmod does not work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •