Find the answer to your Linux question:
Results 1 to 3 of 3
I loaded Postfix from source code, and I cannot get it to start automatically when the server is rebooted. It does not appear in ntsysv. The postfix version is postfix-2.4.6. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    2

    Postfix does not start automatically


    I loaded Postfix from source code, and I cannot get it to start automatically when the server is rebooted. It does not appear in ntsysv. The postfix version is postfix-2.4.6. The linux version is 5.01 I used uname -a and got this information:

    Linux 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:02 EDT 2007 i686 i686 i386 GNU/Linux

    I tried to write a shell script that I found on the web and it did not help. The script was:

    cat > /etc/rc.d/init.d/postfix << "EOF"
    #!/bin/sh
    # Begin $rc_base/init.d/postfix

    # Based on sysklogd script from LFS-3.1 and earlier.
    # Rewritten by Gerard Beekmans - gerard@linuxfromscratch.org

    source /etc/sysconfig/rc
    source $rc_functions

    case "$1" in

    start)
    echo "Starting Postfix..."
    loadproc postfix start
    ;;

    stop)
    echo "Stopping Postfix..."
    loadproc postfix stop
    ;;

    reload)
    echo "Reloading Postfix..."
    loadproc postfix reload
    ;;

    restart)
    $0 stop
    sleep 1
    $0 start
    ;;

    *)
    echo "Usage: $0 {start|stop|reload|restart}"
    exit 1
    ;;
    esac

    # End $rc_base/init.d/postfix
    EOF

    Then I changed mode
    chmod 755 /etc/rc.d/init.d/postfix

    Then I created symbolic links:
    cd /etc/rc.d/init.d &&
    ln -sf ../init.d/postfix ../rc0.d/K25postfix &&
    ln -sf ../init.d/postfix ../rc1.d/K25postfix &&
    ln -sf ../init.d/postfix ../rc2.d/K25postfix &&
    ln -sf ../init.d/postfix ../rc3.d/S35postfix &&
    ln -sf ../init.d/postfix ../rc4.d/S35postfix &&
    ln -sf ../init.d/postfix ../rc5.d/S35postfix &&
    ln -sf ../init.d/postfix ../rc6.d/K25postfix

    Can somebody please help. I am pretty new at linux.
    Thank you

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Is there any particular reason why you need to compile your own version? As far as I know, postfix is available in the RHEL software repositories.

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    2
    Thank you for getting back to me. Yes I tried to get the rpm that was included on the redhat dvd and I could not get it to work. imap and pop3 would not start through dovecot and they were not listening in netstat -a. I could not send anything and nothing was not coming in and smtp was listed has localhost:25. I tried removing the rpm and it just made things worse it would not install again. This happeneded to me twice. Both times the server was wiped and reloaded. So the only way I was able to get it installed was by source

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •