I got a used Creative Zen V Plus for a very god price. I saw that it would work in Linux with gnomad 2.

Now that I have it I am having problems getting the player recognized.

I first tried to install gnomad2 with yum and it didn't find the player. I then took the advice above and compiled against libmtp and had to install a few other dependencies. It still doesn't find the device.

I still get a "no jukeboxes found on USB bus" error message.

I'm running Fedora 7.

I found a post stating "well you first need to have built and installed libmtp, and during the configure stage of gnomad, just point it to the libmtp libs and headers"

I had originally thought it was some configuration setting after I fire up gnomad, but, am thinking it is an option or something when I do ./configure

I also found that there are sometimes problems with usb devices witha kernel of 2.6.1 or higher. It advises:

In the 2.6.10 kernel the method of enumerating devices was changed to follow a similar algorithm as Windows (while the standard allows both many devices require the Windows method). It seems some devices do not like this new method though. If you have started having a problem since this kernel with some of your devices you might want to use the option "old_scheme_first=y" with the usbcore module.

I can't find a file by the name of usb core or know what they are referring to.

If I do: lsusb I can see the device.

I'd apreciate any help anyone can give me on this.


Thanks
Reply With Quote