Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11

    Will it be safe, if i do like these steps

    # umount /boot

    # fsck /dev/sda1

    # mount -t auto /dev/sda1 /boot

    Do you think will it work fine or i will have to go for emergency/single user mode to work these commands more safely? still, stuck on here...

  2. #12
    That should be safe.

    The important thing for filesystem checking is to have the drive UNmounted.

  3. #13
    Thanks for your time sdimhoff and other members.
    Sdimhoff, can you please write down the commands with steps 4-6 with the satisfactory result? I am not good in troubleshooting.

    According to my understanding these steps are ...

    # umount /boot/
    #fsck /dev/sda1

    2- if the problems fixed then fine otherwise reboot the server? or i ll have to perform step-3 ???

    3- to format the /dev/sda1
    #mke2fs -j /dev/hda1 or
    #mkfs.ext3 -j /dev/hda1

    I am confused about the steps 4 to 6, can you please explain these steps with commands???

    Should i have to take bakeup of /etc/fstab???

    Waiting for your reply.

    Many thanks and sory for my poor english.

  4. $spacer_open
  5. #14

    I cannot write the exact commands you need as I do not know anything about your system or how it is supposed to be configured (e.g. what bootloader you are using, what your drive setup is, what arch you are using). i will however give you more information and some examples.

    1.) Yes

    2.) If the filesystem checker fixes all of the problems, then you should be fine and can reboot at your leisure. If you do so and are still running into problems then you should repost and give the new errors.

    3- to format the /dev/sda1
    #mke2fs -j /dev/hda1 or
    #mkfs.ext3 -j /dev/hda1
    Now to your question, whether to use mke2fs -j or mkfs.ext3. What you have written here are actually equivalent (unless I'm mistaken). ext3 is a journaled filesystem. mke2fs with the -j flag makes an ext format that is journaled (ext3). I've always just made my boot partions ext2 (I don't know why, and I don't know if there is an advantage) which would just be mke2fs /dev/<device>

    4.) I'm unsure what bootloader you are using.

    Example if you were using grub (courtesy of the gentoo docs)

    >grub --no-floppy # This brings you into the grub prompt (grub>)

    grub> root (hd0,0)
    grub> setup (hd0)
    grub> quit

    Note: If you want to install GRUB in a certain partition instead of the MBR, you have to alter the setup command so it points to the right partition. For instance, if you want GRUB installed in /dev/hda3, then the command becomes setup (hd0,2). Few users however want to do this.

    Here are the red hat documents. It looks like your server may have a gui to help you do this step.

    #Copy over your kernel to the boot partition
    cd /usr/src/linux
    cp arch/<your arch>/boot/bzImage /boot/kernel-2.6.*****

    #Now configure the bootloader
    nano /boot/grub/grub.conf
    timeout 30
    default 0
    root (hd0,0)
    kernel /boot/kernel-2.6.***** #This is the path to the kernel you just copied over
    root=/dev/<your root device here>

    I'm not sure what else I can do for you. Since this is a corporate server I think it would be wise of you to see if there is anyone more familiar with the system before you do this. Also, I think that you should be very liberal with your backups...

  6. #15

    Thanks for your time sdimhoff. I hope it works and I am planning to reboot this server on weekend.
    This post is still open if any one can recommend something more i will really appreciate.
    I am gonna send an other post / question hope to see a good response there as well

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts