Find the answer to your Linux question:
Results 1 to 6 of 6
After updating to most recent kernel (2.6.23.14-107) along with updating kmod-fglrx (8.443.1-2.7.12) from livna, I cannot any longer set my external display to its native resolution (1440 x 1024). I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3

    Native screen resolution?


    After updating to most recent kernel (2.6.23.14-107) along with updating kmod-fglrx (8.443.1-2.7.12) from livna, I cannot any longer set my external display to its native resolution (1440 x 1024). I am on Mobility Radeon 9600 M10 laptop. System->Preferences->Hardware->Screen resolution has 1280 x 1024 as its maximum resolution. I tried to play with xorg.conf adding a "Monitor" section for the external display forcing its resolution to 1440 x 1024, but got a totally blank screen when rebooting instead of the log-in screen.

    What is preventing moving to the native resolution? This is becoming critical as my eyes start hearting.

    Thanks for any tips.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you enabled fglrx-config-display?
    Log in as root and execute this
    Code:
    init 3
    fglrx-config-display enable
    Reboot machine.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3
    Applying the above code resulted in "Driver already enabled" and no change in the screen resolution problem. By the way, init is under /sbin/init and will change the your run level (go back to console). fglrx-config-display is under /usr/sbin/fglrx-config-display.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    By the way, init is under /sbin/init and will change the your run level (go back to console). fglrx-config-display is under /usr/sbin/fglrx-config-display
    If you login as root then there is no need to type /usr/sbin or /sbin before those commands.
    Execute this
    Code:
    cat /etc/X11/xorg.conf | grep driver
    lspci | grep VGA
    Post output here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3
    Here is the output. Before that, I came accross another thread dealing with a similar problem. It seems there is a problem in the fglrx driver.

    FedoraForum.org - FGLRX driver missing higher resolutions

    "cat /etc/X11/xorg.conf | grep driver" yields nothing.

    "lspci | grep VGA":

    01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the contents of xorg.conf file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •