Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I have VMware installed on my laptop, with WinXP-pro as Host and Fedora6 installed under VMware. Since I am short of disk space on Fedora I followed the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    1

    Problems to boot after "adding new disk to VMware machine in Linux"


    Hi all,

    I have VMware installed on my laptop, with WinXP-pro as Host and Fedora6 installed under VMware.

    Since I am short of disk space on Fedora I followed the instructions at:
    Adding a new disk to a VMWare Virtual Machine in Linux | .:MattTopper.com:.
    to add a new disk to my VMware virtual linux machine. Everything worked fine to start with and I could use the new disk space.

    But,
    When I started up the computer this morning and started up VMware, I cannot even start up/boot my virtual machine.

    1) I start up VMware. This is no problem
    2) I chose to start my virtual machine. This looks good, to start with.
    3) When it comes to "installing"/"reading" udev (sorry, don't remember
    exactely what it says), it says [failed].

    Then there are lines ticking *slowly* down saying something like :

    "udevd -event[4352]: wait_for_sysfs: waiting for
    '/sys/devices/pci0000:00/0000:00:10.0/host0/target0:0:15/0:0:15:7/ioerr_cnt'
    failed"

    where the numbers in "event" and "target" change as new lines like this
    one come up. After a while no more new lines show up and nothing else happens.

    Does anyone have any idea why this is?
    One thing I came to think of is that the first "original" hard drive on my
    virtual machine is an "IDE" and the new one I made last night is "SCSI".
    Maybe a confllict??

    I just saw the function "Snapshot" in VMware and thought this maybe could solve my problems by restoring to an earlier "Restore point" as can be done in Windows. But since I haven't made a Snapshot earlier myself, I guess this function is useless...

    Does anyone have any idea of what might be wrong, and how to fix this??
    Alternatively, if there is some way to restore the virtual machine to the original set up. Or if there may be some kind of failsafe mode to be able to correct things (whatever I need to correct??)

    Thankful for any advice and help on this!
    Thanks in advance /Erik

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    have you tried removing the new disk from the configuration? There is a chance since you are using an older version of fedora that it doesn't have good detection for scsi vmware disk, try remaking the disk as IDE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •