Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Question ATI Radeon 9600 Fedora 8 Help


    I am a linux newbie and have been wanting to make the move from XP to F8 so bad that I can taste it. I have just about everything software wise that I need installed and for the most part everything works great except for my video. I have a Radeon 9600 card that I have with dual monitors and I have been unable to get it to work. Right now I can only get one monitor to come up successfully and even then I have been unable to watch even a small video clip without the system crashing immediately on video startup. I have tried installing the drivers from ATI's website without success and am currently using the kmod-fglrx installed through yum. The closest I have gotten so far to a working solution with both monitors working was one with 1024x768 and the other with 800x600 resolution. I would like for both to have 1024x768.

    I have been able to find plenty of instructions for previous release of Fedora but not much with F8 when dealing with this card. When trying out Fedora 6 a few years back I was able to get dual monitors to work with out much trouble.

    Is there anybody out there who can help me with this or is it time for me to get another video card with dual head support? If I do get another video card is there any suggestions on a card that will not give me so much trouble. Thanks in advance for any help or insight that can be provided.

    Here is some more information
    ################################################## ##############################
    # lspci | grep -i VGA
    01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AP [Radeon 9600]
    ################################################## ##############################


    ################################################## ##############################
    # cat /etc/X11/xorg.conf
    # Xorg configuration created by livna-config-display

    Section "ServerLayout"
    Identifier "Multihead layout"
    Screen 0 "Screen0" LeftOf "Screen1"
    Screen 1 "Screen1" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    Option "Xinerama" "on"
    Option "Clone" "off"
    EndSection

    Section "Files"
    ModulePath "/usr/lib/xorg/modules"
    EndSection

    Section "ServerFlags"
    Option "AIGLX" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us+inet"
    EndSection

    Section "Monitor"
    Identifier "Monitor1"
    VendorName "Monitor Vendor"
    ModelName "LCD Panel 1024x768"
    HorizSync 31.5 - 48.0
    VertRefresh 56.0 - 65.0
    Option "dpms"
    EndSection

    Section "Monitor"
    Identifier "Monitor1"
    VendorName "Monitor Vendor"
    ModelName "Samsung SyncMaster 193P/CX910P (Analog)"
    HorizSync 30.0 - 81.0
    VertRefresh 56.0 - 75.0
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "fglrx"
    Option "OpenGLOverlay" "off"
    Option "VideoOverlay" "on"
    EndSection

    Section "Device"
    Identifier "Videocard1"
    Driver "fglrx"
    VendorName "Videocard Vendor"
    BoardName "ATI Technologies Inc RV350 AP [Radeon 9600]"
    Option "OpenGLOverlay" "off"
    Option "VideoOverlay" "on"
    BusID "PCI:1:0:0"
    Screen 1
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "Screen1"
    Device "Videocard1"
    Monitor "Monitor1"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x1024"
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection
    ################################################## ##############################



    My machine specs
    Asus P4S800D-X
    2GB Ram
    500GB Seagate SATA/300
    ATI Radeon 9600 with 256MB
    Dell 1901FP digital monitor
    Samsung Syncmaster 193s
    Last edited by smcqueen; 02-01-2008 at 05:11 AM. Reason: More information

  2. #2

    Got Dual Screens running !

    I was determined to get this working and I guess since nobody replied to this thread that I was the only one having problems with the ATI 9600 and dual screen. So I am posting this here for documentation purposes since I could not find a clear cut path of making this happen.

    Being the newbie I did a clean re-install of F8. Here are the steps i took.

    1. Disconnected the monitor that was connected to the VGA port.

    2. Install Fedora 8 Respin

    3. yum install updates then reboot

    4. Downloaded ati-driver-installer-8-01-x86.x86_64.run have to set to executable

    5. As root i installed the ati driver after driver is installed i ran command:

    aticonfig --initial -force

    then rebooted

    6. Make sure that the correct driver is loaded
    ##############################################
    [root@localhost ~]# fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI RADEON 9600 Series
    OpenGL version string: 2.1.7276 Release
    ##############################################

    7. Make sure the framerate looks good
    #############################################
    [root@localhost ~]# glxgears
    5837 frames in 5.0 seconds = 1167.325 FPS
    11985 frames in 5.0 seconds = 2396.996 FPS
    12090 frames in 5.0 seconds = 2417.849 FPS
    12091 frames in 5.0 seconds = 2418.151 FPS
    10199 frames in 5.0 seconds = 2039.704 FPS
    etc....
    #############################################

    8. Shutdown the system and re-connect the second monitor to VGA port

    9. Reboot

    10. Go to System/Administration/ATI Catalyst Control Center
    Drop down Display Manager
    Select resolution for Monitor 1 and 2
    Select Spanning for monitors
    Click apply (my screen was really messed up but I accepted0
    Reboot

    This worked for me. I hope it helps somebody else.
    Last edited by smcqueen; 02-03-2008 at 09:59 PM. Reason: forgot a step

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •