Find the answer to your Linux question:
Results 1 to 6 of 6
I have 2 hdd,each with 2 partions.XP W/a storage partion and i'm trying to do the same with 2nd hdd. 1st I unallocate all space and create a 10 gig ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    33

    Drive permission problems


    I have 2 hdd,each with 2 partions.XP W/a storage partion and i'm trying to do the same with 2nd hdd. 1st

    I unallocate all space and create a 10 gig fat32 partion (tux)(I want XP to see it to) at the back.

    I intstall Fedora 7 and let it do its own thing.I edit fstab and mount tux.Here is where the problem begins.If I go straight to tux and inquire about permissions, it doesn't know. When I transfer a zip file from XP to tux, it becomes protected w/ user and group being root and I am not the owner.
    Enter terminal and become root.Here is the results of chmod:

    [root@localhost tux]# chmod 777 (file)
    chmod:changeing permissions of (file) (requested 0777,actual 0755): operation not permitted.
    This happens with each value except 755, which it accepts.

    I suspect it might be fstab. Here it is:
    /dev/hdb5 /mnt/tux vfat defaults,users,auto 0 0

    When I open gedit /etc/fstab, a second terminal also opens w/this:
    (gedit:6655):GnomeUI-Warning**:While connecting to session manager: authentication rejected,reason: None of the authentication proticols specified are supported and host based authentication failed.

    I also get an unmount error: device is busy.

    Any one know where i'm going wrong?

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    /dev/hdb5 /mnt/tux vfat defaults,users,auto 0 0
    umask=0 allow read/write access to all users. auto and users options are default and no need to use those.
    Code:
    /dev/hdb5  /mnt/tux  vfat    defaults,umask=0   0   0
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    33
    Quote Originally Posted by devils_casper View Post
    umask=0 allow read/write access to all users. auto and users options are default and no need to use those.
    Code:
    /dev/hdb5  /mnt/tux  vfat    defaults,umask=0   0   0
    That was a bust. It was no longer mounted nor would it let me.I put auto in and reboot,no joy. I put in users and it mounted back up but with the same problem.

    /dev/hdb5 /mnt/tux vfat defaults,unmask=0,users,auto 0 0

    by the way, my original setting came from Linux for non-geeks w/the distro

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the output of fdisk -l command and all the contents of /etc/fstab file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Jan 2008
    Posts
    33
    Thanks for the help but I decided to uninstall Fedora and install Mandriva 8.It does see all file systems.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Fedora also detect all Filesystems but one has to mount partitions manually.
    Anyways, have fun with Mandriva and dont hesitate to start a new thread if you have any question !
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •