Find the answer to your Linux question:
Results 1 to 3 of 3
I'm running a Linux server with Qmail/Vpopmail, Apache, BIND, MySQL and several other services. I recently updated glibc to glibc-2.3.2-27.9.7, which didn't necessarily BREAK Qmail, but it has started causing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    2

    GLIBC rollback?


    I'm running a Linux server with Qmail/Vpopmail, Apache, BIND, MySQL and several other services. I recently updated glibc to glibc-2.3.2-27.9.7, which didn't necessarily BREAK Qmail, but it has started causing some problems. When I start Qmail, I get this error:


    Incorrectly built binary which accesses errno or h_errno directly. Needs to be fixed.


    I'm trying to rollback glibc to 2.2.5-44. If I try it from up2date, the system crashes and reboots. If I try it using rpm -Uvh --force, I get a segmentation fault


    [root@ns1 glibc]# pwd
    /home/derek/glibc
    [root@ns1 glibc]# ls -salt
    total 16208
    4 drwxr-xr-x 2 root root 4096 Jul 28 18:51 .
    4 drwxr-xr-x 11 derek derek 4096 Jul 28 18:51 ..
    10940 -rw-r--r-- 1 root root 11183168 Jul 28 18:40 glibc-common-2.2.5-44.i386.rpm
    3052 -rw-r--r-- 1 root root 3118913 Jul 28 18:39 glibc-2.2.5-44.i386.rpm
    2208 -rw-r--r-- 1 root root 2255469 Jul 28 18:38 glibc-devel-2.2.5-44.i386.rpm
    [root@ns1 glibc]# rpm -Uvh --force glibc-*
    Preparing... ########################################### [100%]
    Segmentation fault
    [root@ns1 glibc]#


    If I try one package at a time, I get dependency errors:


    [root@ns1 glibc]# rpm -Uvh --force glibc-common-2.2.5-44.i386.rpm
    error: failed dependencies:
    glibc > 2.2.5 conflicts with glibc-common-2.2.5-44
    glibc-common = 2.3.2-27.9.7 is needed by glibc-2.3.2-27.9.7
    [root@ns1 glibc]# rpm -Uvh --force glibc-devel-2.2.5-44.i386.rpm
    error: failed dependencies:
    glibc = 2.2.5 is needed by glibc-devel-2.2.5-44
    [root@ns1 glibc]# rpm -Uvh --force glibc-2.2.5-44.i386.rpm
    error: failed dependencies:
    glibc-common = 2.2.5-44 is needed by glibc-2.2.5-44
    glibc < 2.3.2 conflicts with glibc-common-2.3.2-27.9.7
    [root@ns1 glibc]#


    Does anyone have any idea how I could go about getting GLIBC rolled back to 2.2.5-44 without all of these errors?

    Here is some information about my system:


    [root@ns1 derek]# uname -a
    Linux hidinghostnameforsecurity.com 2.4.20-28.7smp #1 SMP Thu Dec 18 11:18:31 EST 2003 i686 unknown

  2. #2
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    why dont you uninstall glibc completely, then just install the eariler version? its simpler then a rollback with all these dependancies.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    2
    Quote Originally Posted by qub333
    why dont you uninstall glibc completely, then just install the eariler version? its simpler then a rollback with all these dependancies.
    I'd love to, but I haven't been able to force uninstall the package. How do you suggest I do that? I tried rpm -e --force glibc-* but that's no good. Is there something I'm missing?

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •