Find the answer to your Linux question:
Results 1 to 3 of 3
hi all ,yum is a gr8 tool for install packages but my yum is giving errors.It first occur when i tried to install xgl ,here is the error [root@localhost ~]# ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Banned
    Join Date
    Jan 2008
    Posts
    20

    Unhappy Yum Problems


    hi all ,yum is a gr8 tool for install packages but my yum is giving errors.It first occur when i tried to install xgl ,here is the error

    [root@localhost ~]# yum install curl
    Gathering header information file(s) from server(s)
    Server: Red Hat Linux 7 - i386 - Base
    retrygrab() failed for:
    http://mirror.dulug.duke.edu/pub/yum...rs/header.info
    Executing failover method
    failover: out of servers to try
    Error getting file http://mirror.dulug.duke.edu/pub/yum...rs/header.info
    [Errno 4] IOError: HTTP Error 404: Not Found
    [root@localhost ~]#

    i m on fedora7 plz tell me how to uninstall yum [i have yum package i will reinstall it]

  2. #2
    Just Joined!
    Join Date
    Feb 2008
    Location
    Calcutta
    Posts
    4
    You can uninstall any package/module by rpm.
    you can check for installed package ( like yum ):
    Code:
    # rpm -qa | grep yum
    then you can uninstall it by:
    Code:
    # rpm -e yum
    btw, it seems that updating yum repositories might help in your case, instead of an un-installation of yum.

    Jagbir

  3. #3
    Banned
    Join Date
    Jan 2008
    Posts
    20
    this is wat i m getting :
    [root@localhost ~]# # rpm -qa | grep yum
    [root@localhost ~]# rpm -qa | grep yum
    yum-updatesd-3.2.8-2.fc7
    yum-3.2.8-2.fc7
    yum-metadata-parser-1.1.0-2.fc7
    [root@localhost ~]# rpm -e yum
    error: Failed dependencies:
    yum = 3.2.8-2.fc7 is needed by (installed) yum-updatesd-3.2.8-2.fc7.noarch
    yum >= 3.2.5-2 is needed by (installed) pirut-1.3.28-1.fc7.noarch
    [root@localhost ~]# rpm -e yum
    error: Failed dependencies:
    yum = 3.2.8-2.fc7 is needed by (installed) yum-updatesd-3.2.8-2.fc7.noarch
    yum >= 3.2.5-2 is needed by (installed) pirut-1.3.28-1.fc7.noarch
    [root@localhost ~]#

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •