Find the answer to your Linux question:
Results 1 to 5 of 5
I have installed fedora 7 on a Lenovo laptop where Windows Vista was installed already. Its now a dual boot system. In the beginning there wasn't any problem but within ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Location
    Khargpur
    Posts
    2

    Failed to start X server in Fedora 7


    I have installed fedora 7 on a Lenovo laptop where Windows Vista was installed already. Its now a dual boot system. In the beginning there wasn't any problem but within few days I got a problem while booting fedora. I get a message which says.....

    Failed to start the X server (your graphical interface). It seems that the pointer device (your mouse) is not set up correctly. Would you like to view the X server output to diagnose the problem?
    <YES> <NO>

    The cursor is highlighted at YES option but even if I press 'enter' or any other button nothing happens. So I am forced to press the shut down button and then restart. The surprising fact is that I do not get the above error always but very frequently. Sometimes I needed to restart 4-5 times to get back into the normal.

    I do not know how to overcome this problem. I'm writing my /etc/X11/xorg.conf file here.....

    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Synaptics" "CorePointer"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics"
    Driver "synaptics"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "auto-dev"
    Option "Emulate3Buttons" "yes"
    Option "LeftEdge" "120"
    Option "RightEdge" "830"
    Option "TopEdge" "120"
    Option "BottomEdge" "650"
    Option "FingerLow" "14"
    Option "FingerHigh" "15"
    Option "MaxTapMove" "110"
    Option "VertScrollDelta" "20"
    Option "HorizScrollDelta" "20"
    Option "MinSpeed" "0.3"
    Option "MaxSpeed" "0.75"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "intel"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

  2. #2
    Linux User glennzo's Avatar
    Join Date
    Sep 2004
    Location
    Salem, Mass
    Posts
    464
    I would boot to run level 3, terminal only. Log in as root. Then copy the current xorg.conf to something like xorg.conf.bak and then copy the backup xorg.conf, xorg.conf~ to xorg.conf. Reboot and see what happens.

    As root type these commands:
    Code:
    cd /etc/X11
    cp xorg.conf xorg.conf.bak
    cp xorg.conf~ xorg.conf
    reboot
    If that doesn't work then you can always copy the backup file back to xorg.conf and you are back to square one. No harm done.

    Code:
    cp xorg.conf.bak xorg.conf
    Glenn
    Powered by Fedora

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Location
    Khargpur
    Posts
    2
    To Glennzo,
    Actually there is no file xorg.conf~ showing in /etc/X11 directory. So the command cp xorg.conf~ xorg.conf didn't work. But I got one good thing from your post. As you said boot the system to run level 3. So, I did that. Now I can enter to graphics window by typing command "startx". So, thank you very much.....

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User glennzo's Avatar
    Join Date
    Sep 2004
    Location
    Salem, Mass
    Posts
    464
    Well, at least you made progress. If I list my /etc/X11 that file is there and should be for most users:
    Code:
    [glenn@toshiba ~]$ ls -la /etc/X11/
    total 92
    drwxr-xr-x   7 root root  4096 2008-01-25 04:08 .
    drwxr-xr-x 115 root root 12288 2008-02-21 11:55 ..
    drwxr-xr-x   2 root root  4096 2007-08-13 10:47 applnk
    drwxr-xr-x   2 root root  4096 2008-01-27 20:36 fontpath.d
    -rwxr-xr-x   1 root root  1052 2007-10-09 17:06 prefdm
    drwxr-xr-x   2 root root  4096 2008-01-19 10:56 twm
    drwxr-xr-x   2 root root  4096 2008-01-20 06:25 xdm
    drwxr-xr-x   4 root root  4096 2008-01-19 11:00 xinit
    -rw-r--r--   1 root root   547 2007-10-12 15:22 Xmodmap
    -rw-r--r--   1 root root   886 2008-01-25 04:08 xorg.conf
    -rw-r--r--   1 root root   807 2008-01-19 16:40 xorg.conf~
    -rw-r--r--   1 root root   492 2007-10-12 15:22 Xresources
    Maybe it's only there if the file has been modified and not there otherwise.
    Glenn
    Powered by Fedora

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    System creates ~ file only when one modify original file.

    Try to reconfigure everything. Execute this
    Code:
    system-config-display --reconfig
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •