Find the answer to your Linux question:
Results 1 to 9 of 9
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    eth0 suddenly inactive on startup


    I'm using Fedora 8, it was working fine for a few weeks, and now for some reason whenever I boot up, eth0 is inactive and I have to activate it manually through System>Administration>Network Device Control before I can connect to the internet.

    If you go to edit the properties of eth0, it is showing that it should "Activate device when computer starts", so I can't really see what the problem is.

    Anyone got any idea what may be wrong?

    Thanks,
    Aaron.

  2. #2
    I'm not a Redhat/Fedora guy, but you could try this:

    go to /etc/sysconfig/networking/devices

    vi ifcfg-eth0

    make sure that the top of the file has ONBOOT=yes

    Let us know if that worked or not.

  3. #3
    I went into /etc/sysconfig/networking/devices

    there wasn't a file called "ifcfg-eth0", but there was one called ifcfg-eth0.bak (possibly created as a backup file by some software, maybe a package update), should I rename this file?
    # Intel Corporation 82562EZ 10/100 Ethernet Controller
    DEVICE=eth0
    BOOTPROTO=dhcp
    HWADDR=00:07:E9:49:6C:85
    ONBOOT=yes

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,798
    If you are using DHCP then you could copy that file to ifcfg-eth0 providing everything is correct.

    Another thing you could do just reconfigure your network interface, this should be under System Settings -> Network.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  6. #5
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416
    One thing I learned the hard way is that a ifcfg-ethX.bak up files can cause problems!! If you want a backup name it something like orig.ifcfg-ethX


    Had this problem on one or two RHEL servers before

    cheers
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

  7. #6
    I'll try both of the suggestions posted, although I didn't actually make the backup file myself (it must have been made automatically by some software).

    Thanks,
    Aaron

  8. #7
    Quote Originally Posted by Aaron_H View Post
    I went into /etc/sysconfig/networking/devices

    there wasn't a file called "ifcfg-eth0", but there was one called ifcfg-eth0.bak (possibly created as a backup file by some software, maybe a package update), should I rename this file?

    Aaron,

    I would do just that, make a new file - name it ifcfg-eth0 - provide it with the same contents as the bak file - save it then restart your network services. Here are the commands to do just that:

    touch ifcfg-eth0
    vi ifcfg-eth0 and enter the file contents
    now type ":wq" without the quotes
    then type "services networking restart" (I believe networking is correct, but it may be network).
    Last edited by nauticalthinker; 03-11-2008 at 10:34 AM. Reason: :x put in a frowning face, which isn't what I wanted. used :wq instead.

  9. #8
    Thanks for the reply nauticalthinker.

    I went into System>Administration>Network (in GNOME)
    Deleted the previous connection and made a new one with the same settings as before, this seems to have fixed the problem.

  10. #9
    Annoying problem, i tried all of the above and it did not work. try this, it seems to have fixed my problem..

    [bash]# chkconfig --level 2345 network on
    [bash]# chkconfig --list network
    [bash]# /etc/init.d/network restart

    www .brennan .id .au/04-Network_Configuration.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •