Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, this is my first posting here. I have been around linux for a little while, but this problem is eluding me. I can install Fedora 2 with no problems, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    1

    HD errors after FC2 Install


    Hello, this is my first posting here. I have been around linux for a little while, but this problem is eluding me.

    I can install Fedora 2 with no problems, but when I reboot and it looks like it is going to go in to the login screen with the pointer it just hangs there. I switch over to a console and notice that my hard drive is displaying a lot of errors. For example: hdi: command timed out. At first I thought maybe my drive was going bad, because I have tried installing FC2 twice with the same issue.

    I have installed Windows 2000 on it and it worked fine. I then installed Slackware 10 and it worked fine as well. I am thinking that FC2 must of a problem with my particular setup. So, has anyone had a problem like this with this type setup?

    Hardware:
    Motherboard - Abit AT72 + onboard HPT374 SATA controller
    CPU - 2.4GHz
    Memory - 512MB
    Hard Drive - 80GB SATA Seagate
    Video - Matrix G400


    Thank you,
    Digiman

  2. #2
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    post these error messages.....
    Linux For Ever!

  3. #3
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    I found a similar problem after installing Fedora Core 1 on a system which already had Gentoo. In setting up /etc/fstab, Gentoo (and maybe Slackware as well) correlates devices by their /dev identity and points them to their respective mount points. Fedora, instead, goes by "LABEL" to name devices. I'm pretty sure that for a given partition, "LABEL" is same as its designated mount point. So for the case of Gentoo (or SW?) with /usr mounted on hda3 and Fedora with /usr mounted on hda7, their /etc/fstab would look kind of like this (I'm not at a Linux machine right now, so this may be a little off):

    Gentoo:
    Code:
    /dev/hda3    /usr   ...........
    Fedora:
    Code:
    LABEL=/usr    /usr   ...........
    Problem is, there are now two different partitions with LABEL=/usr and the OS may get confused. The fix is to change Fedora's fstab to look like Gentoo's (or SW's), but pointing to their correct partition:
    Code:
    /dev/hda7    /usr   ...........
    All: If there be errors, please let us all know.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •