Find the answer to your Linux question:
Results 1 to 3 of 3
Okay so I am extremely new to linux and pretty newbie'ish when it comes to computers all around. I recently installed fedora on one of my machines but then decided ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2008
    Posts
    2

    [SOLVED] Attempting to uninstall fedora..but messed up now GRUB problems.


    Okay so I am extremely new to linux and pretty newbie'ish when it comes to computers all around. I recently installed fedora on one of my machines but then decided I wanted to install XP back instead. I researched how to do this through some forums but I was struggling, and I found a method but I didn't really look into..so I tried it and now I'm stuck helpless. I did the following..

    I went into Terminal and entered the command.
    su-
    rm /*

    ^something along those lines...
    It began removing the entire directory, then restarted.

    Now I am stuck on the GRUB boot loader menu and I can't figure out how to get out of it. I tried putting in the XP disc and changing the BIOS to boot from disk but it just leaves me at a blank screen for hours at end.

    If anyone knows how to help me recover Fedora or go ahead and put XP on still please help! Maybe a program I can download and burn to disc?

  2. #2
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Wow!! That's a novel way to delete an operating system!

    What's happening is that GRUB is running on your Master Boot Record (MBR), and is telling the bios that it should look in the linux partition for the boot information. The problem is that you've deleted this, so grub gets confused and just hangs there.

    The fix is pretty easy. Put in your XP disc, and boot the computer. Choose the option to fix/repair your installation, and type "fixmbr" when you get to the dos command line.

    Simple as that.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  3. #3
    Just Joined!
    Join Date
    May 2008
    Posts
    2
    Haha Yeah I need to read into things before doing them..I don't have much patience.

    Thanks a lot man that worked like a charm!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •