Find the answer to your Linux question:
Results 1 to 7 of 7
I have a Linux server: Dell PE650 running CentOS ... latest version. I want to telnet into it from my laptop running WinXP. Forget SSH forget PuTTY!! I'll get to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2008
    Posts
    5

    Basic Telnet PLEASE


    I have a Linux server: Dell PE650 running CentOS ... latest version. I want to telnet into it from my laptop running WinXP. Forget SSH forget PuTTY!! I'll get to those after a get the basics completed. I've not been able to get clear directions.

    I want to do it at the most basic level: from my dos prompt.

    What exactly do I need to do on the Linux server to have it accept the connection?

    What exactly do I need to type at the dos prompt?

    This is what I get currently:
    C:\>telnet 192.168.1.70
    Connecting To 192.168.1.70...Could not open connection to the host, on port 23:
    Connect failed

  2. #2
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    hi,


    have a look at this for the Server side
    ftp xinet

    the client part(windows) is correct (if the IP address is correct)
    Linux and me it's a love story

  3. #3
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Forgive me if I'm wrong, but it appears you want to get telnet working first since you think that ssh is somehow more complicated, and I'm not at all sure that's true.

    If you're running a redhat/fedora machine, the following steps should get ssh running.
    Code:
    sudo yum install openssh-server
    sudo /etc/init.d/sshd start
    And that's it! If you have a firewall running on your linux box, you'll have to alter it to open port 22, otherwise it should just work.

    On the windows machine, download and run putty.exe, enter the IP of your linux computer into the server box, and give it your username and password.

    Nice and easy.

    Apologies again if this isn't what you want to do.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  4. #4
    Just Joined!
    Join Date
    May 2008
    Posts
    5
    smolloy,
    That is exactly what I want to do ... and have done, but with no luck.

    sshd is running, and I can even connect to it with a laptop running a Live CD ... Fedora, Suse, CentOS ... all work.

    But with PuTTy on WinXP, I get connection refused. So figured command line telnet would be the most basic form.


    Khafa,
    I'll take a look.

    Thanks to both of you

  5. #5
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    It sounds like you've got your server set up correctly, so all we need to do is figure out what's going wrong with PuTTy.

    Just so that I understand, you have successfully connected from other computers (running liveCDs) on the same network as the ssh server. Is this true? Also, is the windows machine on the same network as the server?

    Did you have a browse through PuTTy's settings to see if everything looks correct?

    Is XP's firewall blocking putty's outward connection?
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  6. #6
    Just Joined!
    Join Date
    May 2008
    Posts
    5
    Yes, true, I had two different laptops at different times with three different Live CDs connect via ssh, all on my home network.

    I've gone through each PuTTY setting, and not sure what they all mean, but I have a couple docs that explain, and it looks like they are all okay; have also used the default settings, only adding server address and selecting ssh or telnet (PuTTY automatically selects port 22 or 23). Still "Connection Refused"

    I've had my firewall turned off ... OH wait, I just remembered I have a CheckPoint VPN running as well.

    I stopped it; tried the basic connection on PuTTY;

    It WORKED!!! ssh is working!!

    I'm Kicking myself ... after two weeks of frustration!!

    But Thanking you Smolloy, step one, step two, and step three all in one post

    Thanks a ton!!!!

    Now for X-Windows ... I'm sure I'll be back

  7. #7
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Great Glad I could help.

    If you've connected to a VPN, then your IP will be different, and trying to connect to a 192.168.... address will try to connect you to some computer on the local network -- but on the local network of the VPN, not your computer!

    Someone's firewall must have been lighting up like a Xmas tree when you were trying to connect to their computer!!

    X-windows on PuTTY always trips me up. My default it *won't* work, you have to find the setting to forward X. Also, you have to edit /etc/ssh/sshd_config to allow your server to forward X connections, and restart sshd afterwards.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •