Find the answer to your Linux question:
Results 1 to 2 of 2
Trying to set up dual monitors with two video cards on my box. I'm starting to bang my head against the wall on this one. Any idea on what I'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2008
    Posts
    3

    Dual Monitors in RedHat 5


    Trying to set up dual monitors with two video cards on my box. I'm starting to bang my head against the wall on this one. Any idea on what I'm doing wrong would be greatly appreciated. I'm running to Nvidia cards and two Dell 1907fp monitors.

    Here is a copy of my current xorg.conf file:
    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "Multihead layout"
    Screen 0 "Screen0" LeftOf "Screen1"
    Screen 1 "Screen1" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    Option "Xinerama" "on"
    Option "Clone" "off"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "Dell 1907FP (Analog)"
    HorizSync 30.0 - 81.0
    VertRefresh 56.0 - 76.0
    Option "dpms"
    EndSection

    Section "Monitor"
    Identifier "Monitor1"
    VendorName "Monitor Vendor"
    ModelName "Dell 1907FP (Analog)"
    HorizSync 30.0 - 81.0
    VertRefresh 56.0 - 76.0
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nv"
    VendorName "Videocard Vendor"
    BoardName "nVidia Corporation [GeForce2 MX/MX 400]"
    BusID "PCI:5:9:0"
    Screen 0
    EndSection

    Section "Device"
    Identifier "Videocard1"
    Driver "nv"
    VendorName "Videocard Vendor"
    BoardName "nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
    BusID "PCI:1:0:0"
    Screen 1
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "Screen1"
    Device "Videocard1"
    Monitor "Monitor1"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x1024"
    EndSubSection
    EndSection

    Here is the relevent info from lspci:
    01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)
    05:09.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)

  2. #2
    Just Joined!
    Join Date
    May 2008
    Posts
    3
    Further information:
    Only one screen is lighting up, the one that is attached to my GeForce2 card.
    Identifier "Videocard0"
    Driver "nv"
    VendorName "Videocard Vendor"
    BoardName "nVidia Corporation [GeForce2 MX/MX 400]"
    BusID "PCI:5:9:0"
    Screen 0

    Other screen is dark.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •