Find the answer to your Linux question:
Results 1 to 5 of 5
Hi everybody and thanks in advance! I have installed Fedora 7 in my laptop, and during the installation I get the following message: error opening /dev/sdaa: No such device or ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Posts
    17

    Exclamation /dev folder corrupted. Boot up sequence too long.


    Hi everybody and thanks in advance!

    I have installed Fedora 7 in my laptop, and during the installation I get the following message:
    error opening /dev/sdaa: No such device or address,

    and it gives me the option to cancel or retry. The only option that works is cancel, and after selecting this one, the same error will come up but this time with sdab, and then sdac... sdba, sdbb and so on...

    After finishing the installation, when booting up, the following message comes up:
    error opening /dev/sdaX: No such device or address,

    and this will be shown for every sda that was created when clicking cancel in the installation (it takes more than 20 minutes to boot up).

    When I check the content of the /dev folder, all those files are there, sda, sdaa, sdab... even sg0 to sg100, tty1 to tty63...

    So, does anybody know why this is happening or what could I do to fix it.

    Thanks!

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    fedora 7 is old, fedora 8 or 9 will give you better hardware support, you might have some problems with 7 not being able to support your hardware out of the box

  3. #3
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    hi,



    did you use Fedora default to partition and install?

    Linux names partitions as /dev/sda1 , /dev/sda2, /dev/sdb1 , /dev/sdc1 etc and not /dev/sdaa ( as far as i have seen).

    I run Fedora 7 on both Dell PowerEdge and IBM thinkpad X series and dont have any problem with it.

    what are your hardware spec and your installation process?
    Linux and me it's a love story

  4. #4
    Just Joined!
    Join Date
    Nov 2007
    Posts
    17
    Thanks guys,
    I'm am going too try upgrading to fedora8 and see if it works.
    I'm not doing any partitions as I'm using a program called VMware Server with which I can install Red Hat without partitioning, but as far as I know that shouldn't give me this weird problem.

    Thanks again.

  5. #5
    Just Joined!
    Join Date
    Nov 2007
    Posts
    17
    Thanks for the ideas guys.
    I have tried installing Fedora8 but still the same problem.
    I was thinking about manually erasing all the files in /dev that are giving me problems in the bootup sequence, and just leaving the essential ones (by the way which are these ones?)
    This is how /dev looks like:

    agpgart loop5 sdaa sdbu sdi sg22 sg65 tty1 tty52
    bsg loop6 sdab sdbv sdj sg23 sg66 tty10 tty53
    cdrom loop7 sdac sdbw sdk sg24 sg67 tty11 tty54
    console lp0 sdad sdbx sdl sg25 sg68 tty12 tty55
    core lp1 sdae sdby sdm sg26 sg69 tty13 tty56
    disk lp2 sdaf sdbz sdn sg27 sg7 tty14 tty57
    dm-0 lp3 sdag sdc sdo sg28 sg70 tty15 tty58
    dm-1 MAKEDEV sdah sdca sdp sg29 sg71 tty16 tty59
    fd mapper sdai sdcb sdq sg3 sg72 tty17 tty6
    fd0 mem sdaj sdcc sdr sg30 sg73 tty18 tty60
    fd0u1040 net sdak sdcd sds sg31 sg74 tty19 tty61
    fd0u1120 null sdal sdce sdt sg32 sg75 tty2 tty62
    fd0u1440 nvram sdam sdcf sdu sg33 sg76 tty20 tty63
    fd0u1600 oldmem sdan sdcg sdv sg34 sg77 tty21 tty7
    fd0u1680 parport0 sdao sdch sdw sg35 sg78 tty22 tty8
    fd0u1722 parport1 sdap sdci sdx sg36 sg79 tty23 tty9
    fd0u1743 parport2 sdaq sdcj sdy sg37 sg8 tty24 ttyS0
    fd0u1760 parport3 sdar sdck sdz sg38 sg80 tty25 ttyS1
    fd0u1840 port sdas sdcl sg0 sg39 sg81 tty26 ttyS2
    fd0u1920 ppp sdat sdcm sg1 sg4 sg82 tty27 ttyS3
    fd0u360 ptmx sdau sdcn sg10 sg40 sg83 tty28 urandom
    fd0u720 pts sdav sdco sg100 sg41 sg84 tty29 usbmon0
    fd0u800 ram sdaw sdcp sg101 sg42 sg85 tty3 vcs
    fd0u820 ram0 sdax sdcq sg102 sg43 sg86 tty30 vcs1
    fd0u830 ram1 sday sdcr sg103 sg44 sg87 tty31 vcs2
    floppy ram10 sdaz sdcs sg104 sg45 sg88 tty32 vcs3
    floppy-fd0 ram11 sdb sdct sg105 sg46 sg89 tty33 vcs4
    full ram12 sdba sdcu sg106 sg47 sg9 tty34 vcs5
    fuse ram13 sdbb sdcv sg107 sg48 sg90 tty35 vcs6
    hpet ram14 sdbc sdcw sg108 sg49 sg91 tty36 vcs7
    hvc0 ram15 sdbd sdcx sg109 sg5 sg92 tty37 vcs8
    hvc1 ram2 sdbe sdcy sg11 sg50 sg93 tty38 vcsa
    hvc2 ram3 sdbf sdcz sg110 sg51 sg94 tty39 vcsa1
    hvc3 ram4 sdbg sdd sg111 sg52 sg95 tty4 vcsa2
    hvc4 ram5 sdbh sdda sg112 sg53 sg96 tty40 vcsa3
    hvc5 ram6 sdbi sddb sg113 sg54 sg97 tty41 vcsa4
    hvc6 ram7 sdbj sddc sg12 sg55 sg98 tty42 vcsa5
    hvc7 ram8 sdbk sddd sg13 sg56 sg99 tty43 vcsa6
    initctl ram9 sdbl sdde sg14 sg57 shm tty44 vcsa7
    input ramdisk sdbm sddf sg15 sg58 snapshot tty45 vcsa8
    kmsg random sdbn sddg sg16 sg59 sr0 tty46 VolGroup00
    log root sdbo sddh sg17 sg6 stderr tty47 X0R
    loop0 rtc sdbp sddi sg18 sg60 stdin tty48 XOR
    loop1 scd0 sdbq sde sg19 sg61 stdout tty49 zero
    loop2 sda sdbr sdf sg2 sg62 systty tty5
    loop3 sda1 sdbs sdg sg20 sg63 tty tty50
    loop4 sda2 sdbt sdh sg21 sg64 tty0 tty51

    I'd say quite a mess. If you have any other ideas please let me know.
    Thank you very much!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •