Find the answer to your Linux question:
Results 1 to 9 of 9
Hello, First let me say that im very new to linux so try to work with me here. I finished installing and configuring the OS a few weeks ago and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2008
    Posts
    5

    Smart Card help


    Hello,
    First let me say that im very new to linux so try to work with me here.
    I finished installing and configuring the OS a few weeks ago and began playing with the idea of using my smart card to login to my computer. However while playing with it i enabled smart card login, never finished configuring it, and restarted my computer. At the login screen i put in my user name then it asks for my smart card. if i put my smart card it it recognizes it and asks for my PIN. I put the one in associated with the card but it doesent recognizes it (probably because its not configured at all). I cant access the root with out smart card access either.
    Im running fedora 8 and just did all updates recently.
    Thanks in advance!
    Ben

  2. #2
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    hi,


    you should be able to shortcut to single user(root) from grub .
    then if you know where is the smart card configuration file you just disable it and restart. there you reinstall the smart card
    Linux and me it's a love story

  3. #3
    Just Joined!
    Join Date
    May 2008
    Posts
    5
    Im wondering if you can dumb this down a little for me. I can get to the grub and i know where the configuration file is. how do i move to or edit the configuration file?
    Thanks again!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    hi,


    you do as follows
    1) boot
    2) when grub menu appears select the kernel to boot
    3) hit e
    4) select the second line
    5) hit e
    6) input single at the end of the line
    7) hit enter
    8 ) hit b
    this should drop you in single mode as root with a command prompt

    9) disable the smart card(edit the configuration file etc ... ). you can use
    the usual commands as mv , vi etc
    Linux and me it's a love story

  6. #5
    Just Joined!
    Join Date
    May 2008
    Posts
    5
    Apparently what I thought I was doing was wrong. I need to find the configuration files that can change the settings to login. That is where I can disable smart card login but I dont know where to look. Any suggestions?

  7. #6
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    give us more information about your smart card so that we can try to see where to disable it. i have never used a smart card for login but i think you should be looking for files under /etc/pam.d/.
    Linux and me it's a love story

  8. #7
    Just Joined!
    Join Date
    May 2008
    Posts
    5
    Alas I appriciate the help but I seem to have broke the OS so I simply wiped it and reinstalled. I thank you for your help as I learned more about linux in this day and a half than from all the classes ive taken in school and the books i read.
    Thanks again!

  9. #8
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    you welcome.
    lets have fun with Linux.
    Linux and me it's a love story

  10. #9
    Just Joined!
    Join Date
    Mar 2012
    Posts
    1
    Quote Originally Posted by fattony0522 View Post
    Hello,
    First let me say that im very new to linux so try to work with me here.
    ... However while playing with it i enabled smart card login, never finished configuring it, and restarted my computer. At the login screen i put in my user name then it asks for my smart card. if i p...t all). I cant access the root with out smart card access either.
    Im running fedora 8 and just did all updates recently.
    Thanks in advance!
    Ben
    Problem solved:
    I had the same....
    login as single user and run authconfig --restorelastbackup

    and then you are at work again....

    Hans LX2KW

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •