Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
the reason i can think of is that the process became a zombie.sometimes the only way to get rid of a process is to restart the computer(very scarce though, and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858

    the reason i can think of is that the process became a zombie.sometimes the only way to get rid of a process is to restart the computer(very scarce though, and in most of those cases the process does not harm anymore).
    in your case i would go to the /proc filesystem and try to track the culprit down.

    does it show in top as an active process?
    Code:
    top b n1 i
    Linux and me it's a love story

  2. #12
    Just Joined!
    Join Date
    Jun 2008
    Posts
    38

    Yes

    Yes it does show up in top as active process. Problem here is that it's eating 99% of CPU and there is not way to get rid of that process. I am worried if it happens in production server then downtime would be difficult. Is it a bug in Linux? How can I track this process down

  3. #13
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    im suspecting here an I/O problem. when a process is waiting for I/O you can not kill it (this generally happens when mounting fails).
    so i would use the lsof command to see what files the process is opening.
    then i would trace it like
    Code:
    strace -p PID
    Linux and me it's a love story

  4. #14
    Just Joined!
    Join Date
    Jun 2008
    Posts
    38
    lsof output appears like this, most of the files have "(deleted)":

    afaconv.l 5813 root txt REG 104,2 11396935 20021557 /home/afa_build/work/AFA/main/dist/deploy/jboss/server/afa/deploy/afa/afa-vert.rar/bin/afaconv.linux32 (deleted)
    afaconv.l 5813 root 0r FIFO 0,7 2523565 pipe
    afaconv.l 5813 root 1w FIFO 0,7 2523566 pipe
    afaconv.l 5813 root 2w FIFO 0,7 2523567 pipe
    afaconv.l 5813 root 3r REG 104,2 151307 21151952 /home/afa_build/work/AFA/main/dist/deploy/jboss/server/afa/deploy/afa/afa-vert.rar/form/wio03.1pe (deleted)

    I really don't understand why it will not show up in "ps" though.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •