Find the answer to your Linux question:
Results 1 to 6 of 6
Every time I boot, a new directory is made in /tmp - e.g. /tmp/keyring-gWcdTD - the last 6 characters vary and are obviously generated (time?). Anyway with this directory (and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17

    default keyring problems


    Every time I boot, a new directory is made in /tmp - e.g. /tmp/keyring-gWcdTD - the last 6 characters vary and are obviously generated (time?). Anyway with this directory (and it contains one file - a socket) in place, I have problems with both evolution (mail) and gnome-keyring-manager. Both of these want me to enter the "default keyring password" for which I have no clue how to find. If I delete this directory, both of these programs are now "happy" and no longer want this password.
    I have googled this default keyring problem and none of the solutions seem to really work unless I must now download one more piece of software (I did add the gnome-keyring-manager as I I hoped it would help).
    SO - how do I
    a) find out the default password (I tried root's and mine and ...)
    b) set the default password
    c) perhaps make a permanent fix of this (maybe a permanend .../keyring... directory somewhere)

    I am getting around the problem, but I suspect that my fix is NOT the right thing to do.

  2. #2
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17
    excuse me, I should be more explicit - using fedora 8

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I think you can just remove the default.keyring file in your .gnome2 directory to set a new one.

    Here's another solution:
    Click on Places, Home Folder. You will then need to hit Control+H on your keyboard to view hidden files. (By the way, if you want to always view hidden files, you can click on Edit, Preferences and click the box in front of Show hidden and backup files.) Browse to the folder called .gnome2, and then to the folder called keyrings. Inside it is a file called default.keyring. Delete it and the next time you enter a site or mount with a password, it'll ask for a keyring password, and then you can set a new one.
    Change gnome-keyring password? - Ubuntu Forums

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17
    thanks for the suggestion Tom - but that was exactly what the suggestions on various web sites said - it appears things have changed as there is no such file - I created one called testring by using gnome-keyring -manager AFTER I deleted the directory and socket in /tmp (before that I could do nothing with the manager program)

    Here is the contents of the directory

    .gnome2/keyrings:
    login.keyring testring.keyring

  6. #5
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I believe login.keyring is the default name in Ubuntu now. Did you see the other options at the end of the thread for 8.02, including Keyring Manager (I see you have that one) and Seahorse?

  7. #6
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17
    VERY nice. I deleted the login.keyring file, then gnome-keyring-manager asked me for the password to testring (which I knew), created a new keyring called login with a password I knew and delete testring.

    rebooted and it worked. and now I know the password for Evolution which is what I started out not knowing- thanks a lot!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •