Find the answer to your Linux question:
Results 1 to 4 of 4
Hi. I'm trying to install a server (dell poweredge 2950) with 6 1TB drives that I have set up as a raid-5 (so I have a virtual drive with a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    2

    RHEL Install - 5 TB raid-5 setup Help


    Hi.

    I'm trying to install a server (dell poweredge 2950) with 6 1TB drives that I have set up as a raid-5 (so I have a virtual drive with a 5TB capacity).
    Unfortunately, when I complete the install, the system won't boot. There are errors with the device-mapper leading to a kernel panick and the boot halting.
    I think this has to do with the size of the VD. I have set up other servers with hd's smaller than 2 TB with no problems.

    I believe the solution is to change the block size when the installer is formating the drives, but I can't find the option to do that. I have tried to go into rescue mode and try to manually format it using
    mkfs.ext -b 4096 /dev/hda
    but I get the following error Read-only filesystem while setting up superblock.

    Let me know if you need more information. Any help would be appreciated.

    Thanks

  2. #2
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    make diffrent partitions for "/" "/boot" and "swap" and force them to be primary
    keep them out of raid...

    you can see /proc/mdstat to see that if anyone of device is arrey is failed...

  3. #3
    Just Joined!
    Join Date
    Jun 2008
    Posts
    11
    i could be wrong,
    but boot from the fedora install cd
    selecte the option to resuce installed system
    theres an option to mount ur hd but skip it
    run mkfs.ext -b 4096 /dev/hda < and hopefully that'll do the trick.

  4. #4
    Just Joined!
    Join Date
    Jul 2008
    Posts
    2
    @b2bwild:
    to make the raid I'm using a raid-controller device so when I get to the install linux only sees 1 HD
    In /proc/mdstat
    Code:
    Personalities:
    unused devices: <none>
    So should I try setting up 2 VD's with that and install the os on one (make it like 80 GB or something?). hmm. I might try that.

    @romenyrr
    Once I do that (I tried and it worked), the disk is cleanly formatted. But how do I get linux to install on there without reformatting?

    I'm sorry I'm a bit of a novice with linux and most of what I'm dealing with I don't completely understand.



    Here is where I'm currently at. I installed linux on a smaller partition (like 80 GB) so the volgroup has about 4.5 Tb of free space. The computer boots fine. My plan was to just create a logical volume using all of the free space, but...
    here is the ouptut of vgdisplay
    Code:
    /dev/hda: open failed: No medium found
      --- Volume group ---
      VG Name               VolGroup00
      System ID
      Format                lvm2
      Metadata Areas        1
      Metadata Sequence No  19
      VG Access             read/write
      VG Status             resizable
      MAX LV                0
      Cur LV                2
      Open LV               2
      Max PV                0
      Cur PV                1
      Act PV                1
      VG Size               4.55 TB
      PE Size               32.00 MB
      Total PE              148956
      Alloc PE / Size       2753 / 86.03 GB
      Free  PE / Size       146203 / 4.46 TB
      VG UUID               vr3L5n-Fjh6-eqlI-VY6l-R8v7-mKtt-D2AduQ
    Why /dev/hda: open failed: No medium found?
    And when I do
    Code:
    lvcreate -l100%Free -n backup VolGroup00
      /dev/hda: open failed: No medium found
      device-mapper: reload ioctl failed: Invalid argument
      Aborting. Failed to activate new LV to wipe the start of it.
    What am I doing wrong?

    Edit:
    I tried to create the partition with fdisk but it would limit the size to 2 TB.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •