Find the answer to your Linux question:
Results 1 to 10 of 10
I had edited the file /etc/fstab in redhat 9.0 and made an error there Now I cannot start linux at all, it asks for the root password and lets me ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    4

    fstab changed cannot mount


    I had edited the file /etc/fstab in redhat 9.0 and made an error there

    Now I cannot start linux at all, it asks for the root password and lets me do e2fsck. But I cannot edit the fstab file as it is in read-only mode.

    This is my configuration

    /dev/hda7 contains all the partitions (/boot, /home ect) except swap
    This is a dual boot system with windows in /dev/hda1
    It uses Lilo to boot

    I tried to unmount the system and mount it in read write mode using these commands
    umount /dev/hda7
    mount -t ext3 -o rw /dev/hda7 /

    I got the message
    "according to mtab /dev/hda7 is already mounted in /"

    This happens even when I login as single user mode

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Location
    USA, NE
    Posts
    10
    this you?

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    4

    Yes

    Yes .. Any answers?

  4. #4
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    Can't you try to unmount / and then try to mount it with rw options enabled?

  5. #5
    Just Joined!
    Join Date
    Aug 2004
    Location
    USA, NE
    Posts
    10
    you tried the knoppix thing yet?

  6. #6
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    boot to knoppix
    su root
    edit fstab
    That could be darned inconvenient for someone who maybe doesn't have knoppix....

    madhavsadashiv, did you make a rescue disk or bootable floppy? I don't know about Lilo, but with GRUB, you would be able to enter the boot commands to get you in. With Lilo, is there a way to enter or edit commands instead of booting to one of your OS's?
    /IMHO
    //got nothin'
    ///this use to look better

  7. #7
    Just Joined!
    Join Date
    Aug 2004
    Posts
    4

    Replies

    kriss wrote

    Can't you try to unmount / and then try to mount it with rw options enabled?


    I tried this in two ways

    1.
    umount /dev/hda7
    mount -t ext3 -o rw /dev/hda7 /

    This I explained in my last post


    2.
    mount -O -t ext3 remount , rw /dev/hda7

    This says the device is busy. I started with lilo , typed linux single in boot.
    I also tried linux rescue in boot, they both ended up with the same results

    drakebasher wrote
    madhavsadashiv, did you make a rescue disk or bootable floppy? I don't know about Lilo, but with GRUB, you would be able to enter the boot commands to get you in. With Lilo, is there a way to enter or edit commands instead of booting to one of your OS's?


    Answer- I made a bootable floppy. I dont know about entering or editing commands with lilo. I guess that will be a line worth looking at....


    Redhatgeek wrote
    you tried the knoppix thing yet?

    No I do not have knoppix, I dont know how to try

  8. #8
    Just Joined!
    Join Date
    Jun 2004
    Posts
    40

    can't boot

    use cd1 of redhat and boot in rescue mode. Let it mount your drive, and then edit fstab from there

  9. #9
    Just Joined!
    Join Date
    Aug 2004
    Posts
    4

    Solved

    Yes the linux rescue mode worked

    The files were located in /mnt/sysimage/home/etc folder

    Thanks

  10. #10
    Just Joined!
    Join Date
    May 2006
    Posts
    2
    For anyone coming here because of this issue, the easiest way is to just type

    mount -w -o remount /

    that will mount your filesystem to make it writable and you can then happily do a:

    vi /etc/fstab

    and repair the line that if giving you the trouble.

    :o) Phil

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •