Find the answer to your Linux question:
Results 1 to 8 of 8
Hi All, I have install Fedora 8 i386 on my machine and it's completed successfully. The default screen resolution is 800 * 600, when I trying to change the screen ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    4

    Unhappy Problem in Changing Screen Resolution


    Hi All,

    I have install Fedora 8 i386 on my machine and it's completed successfully. The default screen resolution is 800 * 600, when I trying to change the screen resolution, ofcourse Higher resolution, it say the information is saved to some conf file, please logout and restart the X server.

    Now Problem is, I don't know how to restart the X server. After searching on internet I found someone say please press AIt+Ctrl+Backspace or restart the machine.. I did so but it's still not changed (it's still 800 * 600).

    Could anyone please tell me how to change screen resolution or restart X server ?

    Thanks.

    -R

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Did you reboot machine? New resolutions work after reboot sometimes. In case Resolution doesn't change, execute this
    Code:
    su -
    lspci | grep -i vga
    grep -i driver /etc/X11/xorg.conf
    Post output here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Posts
    4
    Hi,

    Thanks for quick reply. After restart also it didn't changes. Please find the details below :

    [raj@localhost ~]$ su -
    Password:
    [root@localhost ~]# lspci | grep -i vga
    00:0f.0 VGA compatible controller: VMware Inc [VMware SVGA II] PCI Display Adapter
    [root@localhost ~]# grep -i driver /etc/X11/xorg.conf
    Driver "kbd"
    Driver "vmmouse"
    Driver "vmware"
    [root@localhost ~]#

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Fedora is using correct driver for your Graphics Card. Post the contents of /etc/X11/xorg.conf file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Jul 2008
    Posts
    4
    [root@localhost ~]# more /etc/X11/xorg.conf
    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "VMMouse" "CorePointer"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "gb"
    EndSection

    Section "InputDevice"
    Identifier "VMMouse"
    Driver "vmmouse"
    Option "Device" "/dev/input/mice"
    Option "Emulate3Buttons" "yes"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "vmware"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x800" "1280x768" "1280x720" "1152x864" "1024x768" "800x600" "800
    x600" "640x480" "640x480" "640x400" "640x400"
    EndSubSection
    EndSection

    [root@localhost ~]#

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Check your Monitor's Manual for supported Refresh Rates ( HorizSync and VertRefresh ) and add those ( Section Monitor ) in xorg.conf file.
    Log in as root and open /etc/X11/xorg.conf file in Gedit or Kate or anyother text editor.
    Code:
    Section "Device"
     Identifier "Videocard0"
     Driver "vmware"
    EndSection
    
    Section "Monitor"
    	Identifier	"Generic Monitor"
    	Option		"DPMS"
    	HorizSync	30-71
    	VertRefresh	50-100
    EndSection
    
    Section "Screen"
     Identifier "Screen0"
     Device "Videocard0"
     DefaultDepth 24
     SubSection "Display"
     Viewport 0 0
     Depth 24
    Modes "1280x800" "1280x768" "1280x720" "1152x864" "1024x768" "800x600" 
     EndSubSection
     EndSection
    I have added Generic Refresh Rates in above code.
    Save file and reboot machine.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Jul 2008
    Posts
    4
    Quote Originally Posted by devils casper View Post
    Check your Monitor's Manual for supported Refresh Rates ( HorizSync and VertRefresh ) and add those ( Section Monitor ) in xorg.conf file.
    Log in as root and open /etc/X11/xorg.conf file in Gedit or Kate or anyother text editor.
    Code:
    Section "Device"
     Identifier "Videocard0"
     Driver "vmware"
    EndSection
    
    Section "Monitor"
    	Identifier	"Generic Monitor"
    	Option		"DPMS"
    	HorizSync	30-71
    	VertRefresh	50-100
    EndSection
    
    Section "Screen"
     Identifier "Screen0"
     Device "Videocard0"
     DefaultDepth 24
     SubSection "Display"
     Viewport 0 0
     Depth 24
    Modes "1280x800" "1280x768" "1280x720" "1152x864" "1024x768" "800x600" 
     EndSubSection
     EndSection
    I have added Generic Refresh Rates in above code.
    Save file and reboot machine.
    Hi Casper,

    Even this didn't helped.

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Try replacing vmware with vesa.
    Code:
    Section "Device"
     Identifier "Videocard0"
     Driver "vesa"
    EndSection
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •