Hi Guys,

I am trying to install an HP Laser Jet 5Si printer on my Red Hat linux server running RHEL 5.1. I connected the printer to the only serial port(DB-9 male) available on the back of my system. I installed the printer using cups, and selected HP Laser Jet 5Si/MX printer driver and /dev/ttyS0 port. It installed fine. But when I send a test print to the printer it does not print anything. Pinter icon, which shows print jobs says, this test page printed fine, but nothing prints on the printer.
This same printer when connected to a different server works fine, so I am sure printer is not the problem.


What I did so far.........

When I first sent a test print to the printer through CUPS, it gave me an error "/usr/lib/cups/backend/serial failed".
I changed the permissions for /dev/ttyS0 from 660 to 666, that error is gone, but still the printer does not print anything.

crw-rw-rw- 1 root uucp 4, 64 Jul 17 13:30 ttyS0
crw-rw-rw- 1 root uucp 4, 65 Jul 17 10:38 ttyS1


I tried installing the printer on ttyS1, thinking that could be the right port, still no luck with it.

I sent a file to the port directly from the command prompt to the ports /dev/ttyS0 and /dev/ttyS1, nothing printed on the printer, no response from the printer.

I disabled SELinux for a bit to test if SELINX was not blocking the port. No luck.


dmesg | grep tty
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
00:06: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
00:07: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A


setserial -g /dev/ttyS[01]
/dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4
/dev/ttyS1, UART: 16550A, Port: 0x02f8, IRQ: 3

uname -r
2.6.18-8.el5


At this point, I am really clueless. I just dont know how to get this printer to work on the serial port.


I would appreciate any help in fixing this issue.