Find the answer to your Linux question:
Results 1 to 9 of 9
Guys, New to Linux here. I have installed Linux 9 on an i386 box. I try the "make whatis" command which has worked for me in Solaris, but I get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5

    Cannot search man pages


    Guys,

    New to Linux here. I have installed Linux 9 on an i386 box. I try the "make whatis" command which has worked for me in Solaris, but I get back the following message: make: ***No rule to make target 'whatis'. Stop.

    Any suggestions?

    Thanks

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    77
    Have you done ./configure before make?

    Armage

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    No. The man pages are there, but I cannot do a man -k "keyword" , or an arpropos command for that matter. I vaguely remember using a .configure command from within a directory to install apps, but not to set up the man database.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    What distro do you use?

  6. #5
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    Redhad 9. I installed it bloated with everything. I basically want to tool around with it for a couple of months just to pick up where I left off and get comfortable with Linux again. Then, I play to wipe it clean and install the minimal options to set up Snort on it.

  7. #6
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    Then you should be able to install the man pages through up2date if that's still around. If not, check out yum or apt-get for redhat.

    Kriss

  8. #7
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    I think you misunderstand. Man pages are installed. I just need help creating the whatis database.

  9. #8
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    I believe Redhat comes with a "makewhatis" command, have you tried that?

  10. #9
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    Yeah, only I tried "make whatis"...god I'm a dope. I new I was rusty, but this is ridiculous. Thanks a million.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •