Find the answer to your Linux question:
Results 1 to 7 of 7
Running on a Dell 505 laptop Kernel is the '-86' version. After the most recent update, I've run into a problem during the boot process. Basically, the GUI login screen ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    66

    [SOLVED] Fedora 9 Boot Problem


    Running on a Dell 505 laptop
    Kernel is the '-86' version.

    After the most recent update, I've run into a problem during the boot process. Basically, the GUI login screen never comes up. The cycles between flickering and showing the mouse cursor with the loading/busy animation. The only difference I _noticed_, is that the Avahi Daemon failed to start. I don't know why this would cause the problem I'm experiencing now, but it's the only difference during startup that I could see. Of course, that doesn't mean that it is the only difference.

    I don't know if this is related, but prior to shutting my machine down (before this latest problem), a warning appeared telling me that the Default Gnome power management settings were in an error state. As a result, I couldn't suspend from the login screen (hence my shutting the machine down for the night). I was booting my machine up today to see what I could do to figure that particular problem out.

    All of this happened after my most recent update. Unfortunately, quite a few updates/bug fixes/etc were in the list, so I can't remember if there was anything in particular that might be the cause for this issue.

    I am also unable to boot up the machine from the earlier kernel version (-76).
    Last edited by LazarusLong; 07-22-2008 at 02:45 PM. Reason: Addition Information

  2. #2
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    If your keyboard is still active, you can move to another tty (ctrl-alt-f1) to see if there are any error messages.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  3. #3
    Just Joined!
    Join Date
    Oct 2007
    Posts
    66
    Unfortunately, there was no joy on that option. I tried ctrl-alt-F1 and also ctrl-alt-backspace. The one thing I didn't do is cycle through the other F<n> keys on the off chance that a different tty was available.

    The problem I see is that it looks like it is continually trying to load something, fails, and then tries again. I'll cylce through the F<n> keys and see what happens.

    <edit>
    So trying to cycle through the tty's brought no relief. It would briefly display the login line 'localhost login:' and the corresponding tty(<x>) depending on what F<n> key I pressed. However, it would immediately flicker and go back to the original behavior of showing the cursor in a busy state, flickering the screen on and off then showing the cursor again.

    Next step: At boot loader menu, edit the line for the kernel and add 'single' to force this kernel to boot into single user mode with no X session. This should allow me to access the logs and try to figure out what is going on. One possibility suggested to me by a coworker is that the /tmp directory may be full (he's seen this before and that was one of the problems).
    Last edited by LazarusLong; 07-22-2008 at 05:23 PM. Reason: Follow up info

  4. #4
    Just Joined!
    Join Date
    Oct 2007
    Posts
    66
    So now that I've been able to boot up in single mode, I find that I have little idea what I should be looking for. I scanned through dmesg but couldn't find anything that looked like a problem. I also looked through a couple of the Xorg.<n>.log files.

    Anyone have any ideas of what I should be looking for?

  5. #5
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Try df -h first of all and check if you have a full drive.

  6. #6
    Just Joined!
    Join Date
    Oct 2007
    Posts
    66
    The drive being full does appear to be the case, unless I am reading the results of this command wrong.

    /dev/mapper/VolGroup00-LogVol00 Size - 22G Used - 21G Avail - 0 Use&#37; - 100

    I'm not totally clear on how a Volume Group works yet, but I'm assuming things like /tmp are in this VolGroup.

    Thanks for the pointer.

  7. #7
    Just Joined!
    Join Date
    Oct 2007
    Posts
    66
    A full volume was indeed the problem.

    After cleaning out some junk and making some room, the boot process completed and the login screen came up successfully.

    This is what happens when you turn a laptop with a 80G HD into a dual boot machine. So much for the music library...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •