Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
When I reboot my Fedora 9 system, and then try to access the internet, there is no connection. If I go into the "system - administration - services" window from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    15

    network service not start at bootup fedora 9


    When I reboot my Fedora 9 system, and then try to access the internet, there is no connection.

    If I go into the "system - administration - services" window from GUI, and restart the "network" service, the eth0 internet icon in the desktop tray, displays a message that it is now connected, and at that point my connection is restored and I can browse.

    This is repeatable every time I re-boot. How can I get Network service to automatically start at bootup?

    Thanks
    switcher

  2. #2
    Linux Newbie
    Join Date
    Feb 2008
    Location
    Bangalore, India
    Posts
    112
    Code:
    chkconfig --level 35 network on
    reboot the box.
    bigunix.blogspot.com
    Registered Linux User: #476440

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Posts
    15
    Thanks very much for the help.
    I tried the chkconfig command, but it still does the same thing as described in my original message.

    I also ran "chkconfig" command with no options and it reported that "network" is turned "on" in both run level 3 and 5 boots. I also observed that when the system is shutting down it shows "NFS" as "Failed" during the shutdown process. I think that means that the service was not running and could not be shut down.

    Further, when booting up, I have "time sync" set to run during bootup. It shows time sync as "Failed" during bootup without even hesitating on that command line. I think this means that network is not running, so it does not even try to sync the time.

    Any ideas on what could be causing this to occur? (BYW, I just did a full fresh install of fedora 9 on a formatted disk, and the only other thing I have done is apply all the updates, set static IP, and set time sync to run at boot time.

    Thanks

    Switcher

  4. #4
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Do you already have the NIC set to start at boot? You should be able to check that by typing in terminal
    Code:
    system-config-network
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  5. #5
    Just Joined!
    Join Date
    Jul 2008
    Posts
    15
    Yes, The Nic is configured. I can connect and browse after rebooting by simply manually starting the "network" service via the GUI "services" window.

  6. #6
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    can you post the content of the static ip configuration file?
    Linux and me it's a love story

  7. #7
    Just Joined!
    Join Date
    Jul 2008
    Posts
    15
    Thanks very much for the reply.

    I just came back to the forum because I found a solution. I have no idea why this fixed my issue but it did.

    Using the GUI interface, I went to "system-administration-network device control". This brings up the network config window that shows the eth0 nic interface. I double clicked on the eth0 line. This brings up a config window for the eth0 device.

    In that config window there is an option: "Controlled by Network Manager"

    This item was selected (checked). I unselected this item, saved the config and re-booted. Now, when I boot, the system comes up connected to the internet and I can browse when I run the browser without having to start network service.

    This is repeatable--If this option is selected the system boots up with network service off. If this item is not selected the system boots with network service on.

    The odd thing is that the desktop tray nic icon (looks like two terminals side by side) now has a red X next to it. Normally a red x next to something means it is not working. However, the nic is working and connects to the internet.

    Thanks to everyone for the comments and suggestions. They gave me ideas and helped me find the problem.

    If any knows why this option causes this behaviour, I would appreciate knowing the reason. Also would like to know why the icon has a red X next to it.

    Thanks

    Switcher

  8. #8
    Just Joined! king_rero's Avatar
    Join Date
    Mar 2007
    Location
    rero's kingdom
    Posts
    15
    Quote Originally Posted by switcher1 View Post
    Thanks very much for the reply.

    I just came back to the forum because I found a solution. I have no idea why this fixed my issue but it did.

    Using the GUI interface, I went to "system-administration-network device control". This brings up the network config window that shows the eth0 nic interface. I double clicked on the eth0 line. This brings up a config window for the eth0 device.

    In that config window there is an option: "Controlled by Network Manager"

    This item was selected (checked). I unselected this item, saved the config and re-booted. Now, when I boot, the system comes up connected to the internet and I can browse when I run the browser without having to start network service.

    This is repeatable--If this option is selected the system boots up with network service off. If this item is not selected the system boots with network service on.

    The odd thing is that the desktop tray nic icon (looks like two terminals side by side) now has a red X next to it. Normally a red x next to something means it is not working. However, the nic is working and connects to the internet.

    Thanks to everyone for the comments and suggestions. They gave me ideas and helped me find the problem.

    If any knows why this option causes this behaviour, I would appreciate knowing the reason. Also would like to know why the icon has a red X next to it.

    Thanks

    Switcher
    it's the same if you put ur configuration under /etc/sysconfig/network-scripts/ifcfg-eth0

  9. #9
    Just Joined!
    Join Date
    Jul 2008
    Posts
    1

    Smile

    Try again. ^^

    #chkconfig NetworkManager off
    #chkconfig --levels 35 network on
    #/etc/init.d/network restart
    #reboot

  10. #10
    Just Joined!
    Join Date
    Aug 2008
    Posts
    1

    the same problem..

    I have the same problem. i can start manually but not at he boot time.
    Another thing seem the same: if i unplug the net cable and then reinsert, the net don't turn up automatically and i have to do by myself. NetworkManager and network and plugd are started at the boot time.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •