Find the answer to your Linux question:
Results 1 to 2 of 2
connection issue ISP will not cooperate. "We do not support Linux" High Speed Wireless Broadband running on Fedora 9 modem usbstick Frankling CDU680 Connection Scripts provided by isp: Connect script ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4

    wireless broadband connection problem:


    connection issue
    ISP will not cooperate. "We do not support Linux"
    High Speed Wireless Broadband
    running on Fedora 9
    modem usbstick Frankling CDU680
    Connection Scripts provided by isp:
    Connect script - precompiled no source code it detects status of modem and configures the device as modem if necessary.It calls "execute.sh" dialing script.
    [jofish@localhost ~]$ cat Desktop/Linux/execute.sh
    execute.sh code:

    echo "--> CDU680DORA Linux Connection generic\n"
    rm -rf cdu680config wvdialconf_log
    wvdialconf cdu680config > wvdialconf_log
    echo "Carrier Check= no" >> cdu680config
    echo "Stupid Mode= yes" >> cdu680config
    echo "Phone = #777" >> cdu680config
    echo "Username = 9075290567@acsalaska.net" >> cdu680config
    echo "Password = 9075290567" >> cdu680config
    rm -rf wvdialconf_log
    echo "--> Dialing...\n"
    wvdial --config cdu680config
    ================================================== ========

    I have messed with this issue for weeks I have exhausted all my options. This is how far I have taken it:
    when running ./connect

    # sudo tail -f /var/log/messages
    Jul 30 22:43:58 localhost gnome-keyring-daemon[2546]: adding removable location: volume_uuid_8489_F1B4 at /media/CDU680_UMSD
    Jul 30 22:44:03 localhost pppd[3372]: CHAP authentication succeeded
    Jul 30 22:44:03 localhost pppd[3372]: CHAP authentication succeeded
    Jul 30 22:44:03 localhost pppd[3372]: local IP address 216.67.14.13
    Jul 30 22:44:03 localhost pppd[3372]: remote IP address 209.112.163.4
    Jul 30 22:44:03 localhost pppd[3372]: primary DNS address 216.67.0.2
    Jul 30 22:44:03 localhost pppd[3372]: secondary DNS address 209.193.0.2

    Connect script feed back:

    ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    OK
    --> Modem initialized.
    --> Sending: ATDT#777
    --> Waiting for carrier.
    ATDT#777
    CONNECT
    --> Carrier detected. Starting PPP immediately.
    --> Starting pppd at Wed Jul 30 22:43:56 2008
    --> Pid of pppd: 3372
    --> Using interface ppp0
    --> pppd:
    --> pppd:
    --> pppd:
    --> pppd:
    --> local IP address 216.67.14.13
    --> pppd:
    --> remote IP address 209.112.163.4
    --> pppd:
    --> primary DNS address 216.67.0.2
    --> pppd:
    --> secondary DNS address 209.193.0.2
    --> pppd:

    Now this
    [jofish@localhost ~]$ ping yahoo.com
    ping: unknown host yahoo.com
    [jofish@localhost ~]$
    [jofish@localhost ~]$ ping yahoo.com
    ping: unknown host yahoo.com ,
    Now adding default route local IP
    [jofish@localhost ~]$ sudo /sbin/route add default gw 216.67.14.13

    and this works....

    [jofish@localhost ~]$ ping 209.112.163.4 remote IP
    PING 209.112.163.4 (209.112.163.4) 56(84) bytes of data.
    64 bytes from 209.112.163.4: icmp_seq=1 ttl=63 time=573 ms
    64 bytes from 209.112.163.4: icmp_seq=2 ttl=63 time=89.3 ms
    64 bytes from 209.112.163.4: icmp_seq=3 ttl=63 time=77.3 ms
    ^C
    --- 209.112.163.4 ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2137ms
    rtt min/avg/max/mdev = 77.397/246.683/573.293/230.999 ms

    ifconfig shows:

    [jofish@localhost ~]$ /sbin/ifconfig ppp0
    ppp0 Link encap:Point-to-Point Protocol
    inet addr:216.67.14.13 P-t-P:209.112.163.4 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
    RX packets:17 errors:0 dropped:0 overruns:0 frame:0
    TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:1471 (1.4 KiB) TX bytes:1660 (1.6 KiB)

    The modem lights are on but no actual connection.

    deflating and decrypting data packets?
    I know this works with other ISPs.....

    [jofish@localhost ~]$ cat /etc/ppp/options
    lock
    nobsdcomp
    nodeflate


    Please help....!

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Try disabling the Linux firewall, and see if it helps.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •