Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
hi, fedora didnt mount the other filesystems on hard drives automatically, so i did it so, that i added this into /etc/fstab: /dev/sdb1 /media/C fuseblk rw,allow_other,blksize=4096 0 0 /dev/sdb4 /media/E ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    8

    [SOLVED] mounting other filesystems


    hi,
    fedora didnt mount the other filesystems on hard drives automatically, so i did it so, that i added this into /etc/fstab:

    /dev/sdb1 /media/C fuseblk rw,allow_other,blksize=4096 0 0
    /dev/sdb4 /media/E vfat rw 0 0
    /dev/sda1 /media/F vfat rw 0 0

    but /media/C (NTFS) doesnt mount at all,
    the others (FAT32) are write-protected for non-root

    how to fix it ?
    thanks. (fedora 9)

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi libcha !

    Edit /etc/fstab file.
    Code:
    /dev/sdb1  /media/C   ntfs-3g   defaults,umask=0  0 0
    /dev/sdb4  /media/E   vfat   defaults,umask=0  0 0
    /dev/sdb5  /media/F   vfat   defaults,umask=0  0 0
    Save file and execute mount -a command.

    In case it doesn't work, post the output of fdisk -l command here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Posts
    8

    doesnt func yet

    so, the ntfs works fine, but the vfats are still write protected for non-root

    this writes the fdisk -l :

    Disk /dev/sda: 20,0 GB, 20*060*135*424 bytes
    heads: 255, sectors per track: 63, cylinders: 2*438
    Units = cylinders by*16065 * 512 = 8*225*280 bytes
    Disk id: 0xd508d508

    Device Boot Begin End Blocks Id System
    /dev/sda1 * 1 2438 19583203+ c W95 FAT32 (LBA)

    Disk /dev/sdb: 41,1 GB, 41*174*138*880 bytes
    heads: 255, sectors per track: 63, cylinders: 5*005
    Units = cylinders by 16065 * 512 = 8*225*280 bytes
    Disk id: 0x4a00ce80

    Device Boot Begin End Blocks Id System
    /dev/sdb1 * 1 1958 15727603+ 7 HPFS/NTFS
    /dev/sdb2 3513 5005 11992522+ 83 Linux
    /dev/sdb3 3389 3512 996030 82 Linux swap/Solaris
    /dev/sdb4 1959 3388 11486475 c W95 FAT32 (LBA)

    Disk partitions are in wrong order


    i was surprised it was in czech, so i had to translate it
    also i had to write /sbin/fdisk instead fdisk, but this is a peanut
    i have a little question more, how to install samba and mount an xp - shared folder on a second pc ?
    thanks much

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    so, the ntfs works fine, but the vfats are still write protected for non-root
    How did you gain root privileges? su command doesn't modify PATH. Execute su - instead.
    Code:
    su -
    You won't have to type /sbin.


    There isn't any sdb5 partition. Add this code in /etc/fstab file :
    Code:
    /dev/sda1  /media/C  vfat   defaults,umask=0  0 0
    /dev/sdb1  /media/E   ntfs-3g   defaults,umask=0  0 0
    /dev/sdb4  /media/F   vfat   defaults,umask=0  0 0
    Quote Originally Posted by libcha
    i have a little question more, how to install samba and mount an xp - shared folder on a second pc ?
    I think samba is pre-installed in Fedora 9 but I am not sure. I would suggest you to start a new thread for it.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Jul 2008
    Posts
    8
    i made this :
    Code:
    /dev/sdb1  /media/C   ntfs-3g   defaults,umask=0  0 0
    /dev/sdb4  /media/E   vfat   defaults,umask=0  0 0
    /dev/sda1  /media/F   vfat   defaults,umask=0  0 0
    but this is not what i asked to.
    i only need the full-access to the fat32 partitions from non-root. should i use chmod ??


    this is interesting (/etc/mtab):
    Code:
    /dev/sdb4 /media/E vfat rw 0 0
    /dev/sda1 /media/F vfat rw 0 0
    /dev/sdb1 /media/C fuseblk rw,allow_other,blksize=4096 0 0
    should i only add the allow_other option somehow into fstab ???

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    umask=0 enables read/write access for all Regular users. Have you tried it? It should sort out read/write access problems.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Jul 2008
    Posts
    8

    Angry

    yes, i have umask=0 at all of them, but the vfat ones work for write only for root

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the contents of /etc/fstab file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Just Joined!
    Join Date
    Jul 2008
    Posts
    8

    content of fstab

    oh, the specific part of it is above. ^
    |
    the rest is according to me not essential |
    |
    |
    |

  10. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hmmm... There could be duplicate lines or typos in your /etc/fstab file because if umask=0 not working, something is wrong in /etc/fstab file only.

    Execute this
    Code:
    mkdir /media/sda1
    umount /dev/sda1
    mount -t vfat  /dev/sda1  /media/sda1  -o defaults,umask=0
    Check if Regular users have read/write access in /media/sda1 partition.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •