Find the answer to your Linux question:
Results 1 to 9 of 9
It worked with Core 1, but the install always froze with Core 1. I know that core 2 & 3 have serial mouse problems on the installatio, BUT this persists ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5

    Logitech C7 Serial mouse not working with Core2 or 3 t1...


    It worked with Core 1, but the install always froze with Core 1.

    I know that core 2 & 3 have serial mouse problems on the installatio, BUT this persists post-installation. Does anyone know any solutions? I am a relative newbie to the linux world, so plain english appriciated.

    Oh -- and the computer in question does not have a PS2 or USB port, so non-serial mice are out of the question. (Yes, this must be the only pentium 3 in the world with a serial mouse requirement.)

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Location
    New Jersey USA
    Posts
    15
    Splurge on an adapter, there only like $3 and they sell them everywhere.... allthough it is most likey the port....


    ---------------

    Alternitively, you could get a PCI card, it's going to be about $20, but youll have 4 usb ports, so you can use your mouse, and other USB powered things.

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5

    Adapter?

    Adapter? There is no PS2 port on this comp at all. I have a PS2 to Serial adapter, but alas, no combo mouse to work with it, and I'm hard-pressed to find a serial mouse anywhere so far.

    I was hoping there was some way to get this to work, since it is on the list of supported hardware, and worked in Core 1.

    "Buy new hardware" isn't a very fun answer for me.. as it's only a hobby computer at the moment and I have no expendable money at the moment.

  4. #4
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    have you tried to edit your /etc/X11/XF86config file?(section mouse)?
    Linux For Ever!

  5. #5
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    Yeah, I tried via setup, and all it does is occaisionally make the mouse pointer go nuts when the mouse is moved.. it flies around the top left of the screen and does nothing useful.

  6. #6
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by Dalar
    Yeah, I tried via setup, and all it does is occaisionally make the mouse pointer go nuts when the mouse is moved.. it flies around the top left of the screen and does nothing useful.
    Nevermind via "setup". The mouse flies around because the wrong mouse type is configured. As stathisx says, it's in your xf86config file. If the mouse is eratic in the "text mode" console, the mouse type is wrong in gpm (two separate issues). There is no problem at all with serial mice, when configured correctly. I regularly resort to that in my dual processor PIII.
    /IMHO
    //got nothin'
    ///this use to look better

  7. #7
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    Being kinda new to that file.. and to working without a mouse: how do I edit the file in terminal, since I can't do it in X without a mouse?

  8. #8
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    where do I find gpm? The mouse is funny in text mode too.

    How do I know what the mouse driver name is?

  9. #9
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Everything that follows can be learned from the manual pages for XF86Config and vi. At the command prompt, enter "man XF86Config" or "man vi". Some basics: To switch form GUI to console, hit ctrl-alt-F1 or ctrl-alt-F2 up to ...F6. Switch from console to GUI, hit ctrl-alt-F7.

    To modify core files, work as root. Either login as root or, at command prompt, enter su, and then when asked, enter root password

    To use the vi editor, start by entering: vi filename
    hit i to enter "insert" mode to permit actual editing. When finished editing, hit esc and the :wq to write and quit (don't overlook the colon).

    This completes your toolkit. (below, # means the command prompt for the root user: enter the following or equal)

    To fix your mouse in the GUI, you need to edit your XF86 configuration file:
    Code:
    #  vi /etc/X11/XF86Config
    Scroll down to find the section something like:
    Code:
    Section "InputDevice"
    	Identifier   "Mouse0"
    below that, for a plain-vanilla serial mouse make changes for the following lines:
    Code:
    Driver   "mouse"
    Option   "Protocol"   "auto"
    When done, hit esc and :wq to save and exit. If X (the GUI) is running enter it now (ctrl-alt-F7) and then log out. Log in again and cross your fingers.

    To fix your text-mode mouse, check the gpm help file: # gpm -h
    After reading that, you may be inclined to try:
    Code:
    #  gpm -k         (and then...)
    #  gpm -m /dev/mouse -t logi      (wiggle the mouse now and see if it worked)
    (or instead:)
    #  gpm -m /dev/mouse -t bare
    The "/dev/mouse" here and above assumes you have a symbolic link for your serial port to /dev/mouse. To confirm:
    Code:
    #ls -l /dev/mouse        (those are both "L". no numbers here...And the system will return:)
    
    lrwxrwxrwx  1  root  root  10 Aug 15 01:58 /dev/mouse -> /dev/ttyS0
    If not you may need to
    Code:
    rm  /dev/mouse
    ln  -s  /dev/ttyS0  /dev/mouse
    This assumes your mouse is plugged into "com1" (=ttyS0). Otherwise, try ttyS1 instead.

    I hope this is helpful. Read the manual pages and write back with progress or otherwise.
    /IMHO
    //got nothin'
    ///this use to look better

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •