Find the answer to your Linux question:
Results 1 to 5 of 5
I recently installed Fedora 9 and have encountered some weirdness with my network. The network connects fine, and I have full internet access, but applications don't seem to recognise that! ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414

    Fedora 9: Applications always start in "offline" mode


    I recently installed Fedora 9 and have encountered some weirdness with my network. The network connects fine, and I have full internet access, but applications don't seem to recognise that! For example, both firefox and evolution always begin in "offline" mode, and I have to find the menu option to enable online access -- every single time I start them.

    Even worse, the add/remove programs GUI thinks I'm offline and can't connect to the repos to download new software. I have no idea how to tell it that a network connection exists.

    Has anyone seen this before, and does anyone know how to fix it?
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  2. #2
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    No one has any idea about this? Am I the first person to see this?
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  3. #3
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    I have also seen this, I fixed it by disabling then enabling my network device. Not sure whats the cause of it though.

  4. #4
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    *Finally* figured this one out.

    For some reason my eth0 was set to be controlled from the network control panel, not Network Manager. When I clicked to enable control by Network Manager, everything started working as it should.
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  5. #5
    Just Joined!
    Join Date
    Oct 2008
    Posts
    1

    That did it.

    Thanks so much for the tip. I was pulling my hair out!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •