Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I am running Samba 2.0.7 on linux Redhat 7 kernel 2.2.22 as shown below. # uname -a Linux serv 2.2.22-7.0.3smp #1 SMP Thu Nov 14 11:51:44 EST 2002 i686 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    3

    Excel Files opens as read only with samba 2


    Hello,
    I am running Samba 2.0.7 on linux Redhat 7 kernel 2.2.22 as shown below.
    # uname -a
    Linux serv 2.2.22-7.0.3smp #1 SMP Thu Nov 14 11:51:44 EST 2002 i686 unknown
    # /usr/sbin/smbd -V
    Version 2.0.7

    I have a problem with excel files on share point which somtimes opens as a read only files, but I'm sure that only one person is using them at the same time.
    I found an article which explains to add to the smb.conf the two lines:
    force security mode = 0200
    dos filemode = yes
    which didn't solve my problem.
    when restarting the samba server I found in the /var/log/samba/log.smb: (samba log file)
    [2004/08/25 16:48:14, 0] param/loadparm.c:map_parameter(1681)
    Unknown parameter encountered: "dos filemode"
    [2004/08/25 16:48:14, 0] param/loadparm.c:lp_do_parameter(2223)
    Ignoring unknown parameter "dos filemode"
    So I guess this command is working on later versions, and I'm trying to find the similar command which will work with this samba version,
    or to find any other suggestions to solve this problem
    below is the global part from the smb.conf and the relevant share point:
    [global]
    workgroup = WORKGROUP
    server string = Samba Server
    interfaces = eth0 eth0:0
    encrypt passwords = Yes
    log file = /var/log/samba/log.%m
    max log size = 100
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    domain master = No
    dns proxy = No
    [morel work]
    path = /home/morel/work
    force directory mode = 0770
    writeable = yes
    create mode = 0770
    force create mode = 0770
    directory mode = 0770
    force group = Finance
    valid users = @Finance
    comment = morel work
    write list = @Finance
    force security mode = 0200
    dos filemode = yes

    I would appriciate any help,

    Thanks in advance

    Aviad.

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    So the files are on a remote Windows machine and you're trying to open them on the local Linux machine? If that's the case, then try changing the the fmask option of smbmount. smbmount is what actually mount the Windows machine on Linux. It may be in your fstab file as well.

    http://www.samba.org/samba/docs/man/smbmount.8.html

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    3
    This is not the case here,
    the files are stored in the linux machine, where the samba server is installed, and the user is opening them on a windows XP machine with Office 2k.

  4. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Drat!

    Okay... What I would do if I were you would be to comment out all of the mode stuff from under [more work], including the force and what not. This will give everyone access to share, so if you're worried about security then don't do that. See if you still have the problem. Then one by one, uncomment them until the problem resurfaces.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •