Find the answer to your Linux question:
Results 1 to 4 of 4
I had until yesterday a nice set up (or so I thought) FC2 on my master drive Win2000 on my slave drive The two OS were totaly independant as I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    3

    GRUB and dual disk boot.


    I had until yesterday a nice set up (or so I thought)
    FC2 on my master drive
    Win2000 on my slave drive

    The two OS were totaly independant as I install each of them with only their respective drive in the box (so both thought they'd been install on the master drive, linux doesn't care but win does)

    After that, I edited Grub, the usual stuff for linux (no problem from this side)
    for win I had:

    map (hd0) (hd1)
    map (hd1) (hd0)
    rootnoverify (hd1,0)
    chainloader +1

    Until yesterday this was working fine booting win straight away from Grub, and from the drive if I ever put only the win drive in the box.

    Now, grub doesn't want to boot win anymore, and I get a blank screen just after the Grub boot sequence (linux works fine) The funny things is that I didn't change anything, and that the win drive boot just as usual if it is alone (that is as a master drive) or if I specify to the Bios to boot from the slave drive.

    So any Idea what went wrong? I was so proud of this etup, so easy to manage my multi win re-install, just un plug the linux drive and go, but now it is just broken, what's wrong?

    mat

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    IMO: Too complicated. keep FC as master, Win as slave, keep both in the box (they won't fight). Delete the two lines "map ..." and you should be able to boot either way. Try this:

    Boot. When GRUB comes up, hit up or down to select Windows. Hit e to edit. You will see the command list you showed in your message. After reading the instructions, you will see that you can hit d to delete the first line, hit d to delete the second line (map....) and then either enter or boot (read the instructions) to boot. If Windows opens sucessfully, you will know that that's your error. The best part is, the editing is not permanent, so you can try variations until you get it right: but take notes so you can fix it right once you find the right fix.
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    3

    That is what I tried

    But the thing is that it worked just perfectly before, with th esame settings! So something changed without me knowing and ****ed it up.

    The other thing is that now and then my slave drive disappear at boot, i don't know where it is coming from, the ide cable seems fine and i tried it as master, slave on both connector with and without another drive, but the drive ramdomly disappear at boot, I guess something like that may have ****ed it up, let say i didn't realise the slave drive was not recognize and i tried to boot it with grub, could that mess it up?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Yeah, I'm with you on the mysteries of GRUB. I've posted a few, with and without rants. My working theory is that it has to do with how GRUB identifies the drives and how we get confused with that. And if you have an intermittant problem with one of your drives, that only compounds the confusion.

    If, during BIOS booting, you don't see all of the drives you should, that's got nothing to do with GRUB. I have a SCSI drive I can't trust because sometimes it disappears during the SCSI BIOS routine. And I recently had some problems with IDE drives that I decided were caused by the ribbon cable, for lack of a better cause.

    As I mentioned before, you can edit GRUB during booting without making a permanent change, so there is no harm in changing rootnoverify (hd1,0) to rootnoverify (hd0,0). If it doesn't boot, no loss. If it does, you get smarter. Good luck.
    /IMHO
    //got nothin'
    ///this use to look better

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •