Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
HI... i am using fedora 9... i have nvidia 7200gs graphics card... i tried installing using the command [root@localhost Harish]# yum -y install kmod-nvidia Loaded plugins: refresh-packagekit livna | 2.1 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2005
    Posts
    176

    NVIDIA 7200Gs installation


    HI... i am using fedora 9... i have nvidia 7200gs graphics card...
    i tried installing using the command
    [root@localhost Harish]# yum -y install kmod-nvidia
    Loaded plugins: refresh-packagekit
    livna | 2.1 kB 00:00
    http://ftp.iitm.ac.in/fedora/release...ta/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
    Trying other mirror.
    fedora | 2.4 kB 00:00
    adobe-linux-i386 | 951 B 00:00
    updates | 2.6 kB 00:00
    Setting up Install Process
    Parsing package install arguments
    Resolving Dependencies
    --> Running transaction check
    ---> Package kmod-nvidia.i686 0:173.14.12-3.lvn9 set to be updated
    --> Processing Dependency: kmod-nvidia-2.6.25.14-108.fc9.i686 = 173.14.12-3.lvn9 for package: kmod-nvidia
    --> Running transaction check
    ---> Package kmod-nvidia-2.6.25.14-108.fc9.i686.i686 0:173.14.12-3.lvn9 set to be updated
    --> Processing Dependency: nvidia-kmod-common >= 173.14.12 for package: kmod-nvidia-2.6.25.14-108.fc9.i686
    --> Processing Dependency: kernel-uname-r = 2.6.25.14-108.fc9.i686 for package: kmod-nvidia-2.6.25.14-108.fc9.i686
    --> Running transaction check
    ---> Package kmod-nvidia-2.6.25.14-108.fc9.i686.i686 0:173.14.12-3.lvn9 set to be updated
    --> Processing Dependency: kernel-uname-r = 2.6.25.14-108.fc9.i686 for package: kmod-nvidia-2.6.25.14-108.fc9.i686
    ---> Package xorg-x11-drv-nvidia.i386 0:173.14.12-1.lvn9 set to be updated
    --> Processing Dependency: xorg-x11-drv-nvidia-libs = 173.14.12-1.lvn9 for package: xorg-x11-drv-nvidia
    --> Processing Dependency: livna-config-display for package: xorg-x11-drv-nvidia
    --> Processing Dependency: livna-config-display for package: xorg-x11-drv-nvidia
    --> Running transaction check
    ---> Package kmod-nvidia-2.6.25.14-108.fc9.i686.i686 0:173.14.12-3.lvn9 set to be updated
    --> Processing Dependency: kernel-uname-r = 2.6.25.14-108.fc9.i686 for package: kmod-nvidia-2.6.25.14-108.fc9.i686
    ---> Package xorg-x11-drv-nvidia-libs.i386 0:173.14.12-1.lvn9 set to be updated
    ---> Package livna-config-display.noarch 0:0.0.20-1.lvn9 set to be updated
    --> Finished Dependency Resolution
    kmod-nvidia-2.6.25.14-108.fc9.i686-173.14.12-3.lvn9.i686 from livna has depsolving problems
    --> Missing Dependency: kernel-uname-r = 2.6.25.14-108.fc9.i686 is needed by package kmod-nvidia-2.6.25.14-108.fc9.i686-173.14.12-3.lvn9.i686 (livna)
    Error: Missing Dependency: kernel-uname-r = 2.6.25.14-108.fc9.i686 is needed by package kmod-nvidia-2.6.25.14-108.fc9.i686-173.14.12-3.lvn9.i686 (livna)


    can any one tell me the method to install using yum ??

  2. #2
    Linux Newbie tiersen's Avatar
    Join Date
    May 2008
    Location
    Tokyo,Japan
    Posts
    226
    yum -y update
    yum -y install kmod-nvidia
    "If we lived in a world where the better technology won out, then no doubt everybody and their aunt Fanny would be using GNU/Linux"
    Sam Varghese

  3. #3
    Linux Newbie
    Join Date
    Nov 2005
    Posts
    176
    i get the following error after running
    yum -y update

    Running Transaction
    Installing: unique ####################### [ 1/11]
    Updating : fedora-release ####################### [ 2/11]
    Updating : PackageKit-libs ####################### [ 3/11]
    Updating : PackageKit ####################### [ 4/11]
    Updating : yum-packagekit ####################### [ 5/11]
    Updating : gnome-packagekit ####################### [ 6/11]
    Cleanup : PackageKit ####################### [ 7/11]
    Cleanup : yum-packagekit ####################### [ 8/11]
    Cleanup : gnome-packagekit ####################### [ 9/11]
    Could not parse file '/usr/share/applications/ymessenger.desktop': Key file contains unsupported encoding 'Legacy-Mixed'
    Cleanup : fedora-release ####################### [10/11]
    Cleanup : PackageKit-libs ####################### [11/11]
    ERROR:dbus.connection:Unable to set arguments () according to signature u's': <type 'exceptions.TypeError'>: More items found in D-Bus signature than in Python arguments
    Traceback (most recent call last):
    File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
    File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
    File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
    File "/usr/share/yum-cli/cli.py", line 432, in doTransaction
    self.runTransaction(cb=cb)
    File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 790, in runTransaction
    self.plugins.run('posttrans')
    File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 175, in run
    func(conduitcls(self, self.base, conf, **kwargs))
    File "/usr/lib/yum-plugins/refresh-packagekit.py", line 37, in posttrans_hook
    packagekit_iface.StateHasChanged('posttrans')
    File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
    File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
    File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 597, in call_blocking
    message.append(signature=signature, *args)
    TypeError: More items found in D-Bus signature than in Python arguments

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute this
    Code:
    ls /etc/yum.repos.d
    Post output here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Sep 2008
    Posts
    2
    hi all!

    i have this problem too:/

    here it is my repos:

    [root@alexander yum.repos.d]# ls -1 /etc/yum.repos.d
    adobe-linux-i386.repo
    atrpms.repo
    fedora-rawhide.repo
    fedora.repo
    fedora-updates-newkey.repo
    fedora-updates.repo
    fedora-updates-testing-newkey.repo
    fedora-updates-testing.repo
    freshrpms.repo
    google.repo
    jpackage.repo
    livna-devel.repo
    livna.repo
    livna-testing.repo

    ..this dependency is funny, because yesterday i installed fc9.. - the difference only was the arch amd 64 - and everythink worked fine...

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You have installed a lot of conflictiong repositories. Move these files to some other place and try again.
    adobe-linux-i386.repo
    atrpms.repo
    fedora-rawhide.repo
    fedora-updates-newkey.repo
    fedora-updates-testing-newkey.repo
    fedora-updates-testing.repo
    freshrpms.repo
    google.repo
    jpackage.repo
    livna-devel.repo
    livna-testing.repo
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Just Joined!
    Join Date
    Sep 2008
    Posts
    2
    it's not resolved the problem...:/ i think the problem with the update the many of repos..

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Execute this
    Code:
    yum clean all
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #9
    Linux Newbie
    Join Date
    Nov 2005
    Posts
    176
    i get the following output after running
    yum clean all
    Loaded plugins: refresh-packagekit
    Existing lock /var/run/yum.pid: another copy is running as pid 2716.
    Another app is currently holding the yum lock; waiting for it to exit...
    Another app is currently holding the yum lock; waiting for it to exit...

    please resolve the issue.............

  11. #10
    Just Joined! sanjaykatiyar's Avatar
    Join Date
    Mar 2007
    Location
    Bangalore
    Posts
    97
    Looks some instance of yum is running in background.
    Stop all the process of yum first then do the yum clean all.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •