Find the answer to your Linux question:
Results 1 to 8 of 8
Hello, I'm new with Fedora. I use Fedora 9 Sulphur (x86_x64). I want to install new packages from my dvd, the same dvd I used to install Fedora 9. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    9

    Exclamation Repomd.xml


    Hello, I'm new with Fedora. I use Fedora 9 Sulphur (x86_x64). I want to install new packages from my dvd, the same dvd I used to install Fedora 9.

    I put the dvd on my dvd player and Fedora mounts it.

    But I have a problem, when I click on a package from de window installer, the installer shows me a window with this message:

    Error: Cannot retrieve repository metadata (repomd.xml) for repository: updates. Please verify its path and try again

    I try to do the same using yum via console, but I have the same problem.

    I don't understand. Fedora mounts the dvd, but I suppose the installer doesn't have associated from where it have to install packages.

    So, I install rpm packages via console going into .../Packages, but I want to use yum or the installer.

    Can someone help me?

  2. #2
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    hi,

    to install a package from the DVD with yum check this one
    Linux and me it's a love story

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    9

    Exclamation No network connection available

    Hello, thank you for your answer khafa.

    I did it and it shows me packages to install!

    I didn't install games, so I wanted to try to install them. But when I selected games/gnome-games-1:2.22.1.1-4.fc9 (x86_64) and clicked on the Install button it shows me a new window with this message:

    No network connection available
    Cannot install when offline

    I don't understand, I told it to install from dvd (with the *.repo file), so, what's wrong?

  4. #4
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    have tried installing from the command line(with yum) ?
    Linux and me it's a love story

  5. #5
    Just Joined!
    Join Date
    Sep 2008
    Posts
    9
    I have tried something like:

    yum clean all
    yum makecache

    and

    yum install gnome-games-1:2.22.1.1-4.fc9.rpm

    "clean all" and "makecache" runs well, but I don't remember the error with "install". I think so it said it didn't find the package. I need to read about yum, I'm new on Linux. I just know it is a command to install rpm packages and their dependencies.

    I tried using rpm command going where I have mounted my dvd player and it runs well except when the package has dependencies where I need yum or install each dependencies with rpm (I prefer yum).

  6. #6
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    run the following to see if yum sees your games and if its the case you install with yum
    Code:
    yum --disablerepo=* --enablerepo=<the repo for the dvd> info gnome-games
    if this returns the packages then you have it.
    install it as follows
    Code:
    yum --disablerepo=* --enablerepo=<the repo for the dvd> install gnome-games
    Linux and me it's a love story

  7. #7
    Just Joined!
    Join Date
    Sep 2008
    Posts
    9

    Exclamation

    Hello khafa. Well, I tried it. I could install packages! And that in part resolved another problem I had.

    When I unpackaged eclipse (eclipse-java-ganymede-linux-gtk-x86_64.tar.gz) it showed me the splash and then closed. See this if you are interested:

    http://www.linuxforums.org/forum/red...edora-9-a.html

    So, I decided to install eclipse-mylyn from the repository (dvd), it runs fine but then I uninstalled it. When I executed the previous eclipse (I had unpackaged) it ran!

    Then I uninstalled some packages like jakarta-commons..., but I didn't uninstall some packages like glibc... because thank them I could run my unpackaged eclipse.

    Thank you for your help khafa!

  8. #8
    Linux Engineer khafa's Avatar
    Join Date
    Apr 2008
    Location
    Tokyo, Japan
    Posts
    858
    you very welcome
    Linux and me it's a love story

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •